3610db4686abe6166aa13523f9145ca5b37b2d17
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r28"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   claws-mail \
15   swfdec swfdec-gnome swfdec-mozilla \
16   firefox \
17 #  gnumeric \   
18 #  gimp \
19   networkmanager network-manager-applet \ 
20 #  synergy \
21   vnc x11vnc angstrom-x11vnc-xinit \
22 #  xchat \
23   xournal \
24 "
25
26 BLUETOOTH_GUI = " \
27   blueman \
28   gnome-bluetooth \
29 "
30
31 IM_CLIENT = " \
32   pidgin \
33   libpurple-protocol-msn \
34   libpurple-protocol-yahoo \
35   libpurple-protocol-icq \
36   libpurple-protocol-aim \
37 "
38
39 DISPMAN = " \
40   slim \
41   slim-op-themes \
42 "
43
44 FONTS = " \
45   font-adobe-75dpi \
46   fontconfig fontconfig-utils font-util \
47   ttf-arphic-uming \
48   ttf-dejavu-common \
49   ttf-dejavu-sans \
50   ttf-dejavu-serif \
51   ttf-dejavu-sans-mono \
52   ttf-liberation-sans \
53   ttf-liberation-serif \
54   ttf-liberation-mono \
55   xorg-minimal-fonts \
56 "  
57
58 # Any default games we want to ship.
59 GAMES = " \
60   scummvm \
61 #  frozen-bubble \
62   gnome-games \  
63 "
64
65 GNOME_APPS = " \
66   gnome-mplayer \
67 #  gcalctool \ 
68   gnome-keyring gnome-keyring-pam-plugin \
69   gksu \
70 "
71
72 GNOME_GTK = " \
73 #  gnome-icon-theme \
74 #  angstrom-gnome-icon-theme-enable \
75 "
76
77 GSTREAMER = " \
78 #  gstreamer-ti \
79   gst-ffmpeg \
80   gst-omapfb \
81 #  gst-plugin-pulse \
82   gst-plugin-xvimagesink \
83   gst-plugins-base-meta \
84   gst-plugins-good-meta gst-plugins-bad-meta \
85 #  gst-plugins-ugly-meta \
86 "
87
88 ICON_THEME = " \
89   hicolor-icon-theme \
90   elementary-icon-theme \
91   elementary-icon-theme-enable \
92 "
93
94 LAUNCHERS = " \
95   netbook-launcher-efl \
96 "
97
98 PANDORA = " \
99   pandora-first-run-wizard hsetroot \
100   pandora-scripts \
101   pandora-wallpaper-official pandora-wallpaper-community \
102   pandora-xfce-defaults \
103   pandora-xmms-defaults xmms \
104   pandora-midori-defaults midori \
105   pandora-pmenu libgles2d \
106 "
107
108 PERL = " \
109   perl \
110   task-perl-module-all \
111   libnet-dbus-perl \
112   libxml-parser-perl \
113   libxml-twig-perl \
114 "
115
116 PULSEAUDIO = " \
117 #  pulseaudio-alsa-wrapper \
118 #  pulseaudio-esd-wrapper \
119 #  pulseaudio-module-gconf \
120 #  libasound-module-ctl-pulse \
121 #  libasound-module-pcm-pulse \
122 "
123
124 QT_SELECTED = "qt4-x11-free"
125 #  qt4-x11-free-gles \
126
127 QT_SUPPORT = " \
128   ${QT_SELECTED} \
129 "
130
131 # We want all of the Qt metapackage (for dev use) without the demos/examples.
132 BAD_RRECOMMENDS += " \
133   ${QT_SELECTED}-demos \
134   ${QT_SELECTED}-examples \
135 "
136
137 TOTEM = " \
138   totem \
139   totem-browser-plugin \
140   totem-plugin-bemused \
141   totem-plugin-gromit \
142   totem-plugin-media-player-keys \
143   totem-plugin-ontop \
144   totem-plugin-properties \
145   totem-plugin-screensaver \
146   totem-plugin-skipto \
147   totem-plugin-thumbnail \
148 "
149
150 TOUCHSCREEN = " \
151   gtk-touchscreen-mode-enable \
152   libgtkstylus \
153   xinput-calibrator \
154 "
155
156 XFCE46_BASE = " \
157   xfce4-dev-tools \
158   xfwm4 \
159   xfwm4-theme-default \
160   xfce-utils \  
161   xfce4-session \     
162   xfconf \
163   xfdesktop \
164   xfce4-panel \
165   xfce4-power-manager \
166   \
167   gtk-xfce-engine \
168   \
169   xfce4-panel-plugin-actions \
170   xfce4-panel-plugin-clock \
171   xfce4-panel-plugin-iconbox \
172   xfce4-panel-plugin-launcher \
173   xfce4-panel-plugin-pager \
174   xfce4-panel-plugin-separator \
175   xfce4-panel-plugin-showdesktop \
176   xfce4-panel-plugin-systray \
177   xfce4-panel-plugin-tasklist \
178   xfce4-panel-plugin-windowlist \   
179   xfce4-settings \
180   xfce-terminal \
181   thunar \
182 "
183
184 XFCE46_EXTRAS = " \
185   xfce4-notifyd \
186   xfce4-mixer \
187   xfce4-appfinder \
188   xfprint \    
189   orage \
190   squeeze \
191   ristretto \
192   mousepad \ 
193   gigolo \
194 "
195
196 XFCE_THEMES = " \
197   xfwm4-theme-daloa \
198   xfwm4-theme-moheli \
199 #  xfwm4-theme-default-4.0 \
200 #  xfwm4-theme-default-4.2 \
201 #  xfwm4-theme-default-4.4 \
202   xfwm4-theme-kokodi \
203   xfwm4-theme-sassandra \
204 #  xfwm4-theme-stoneage \
205 #  xfwm4-theme-therapy \
206 #  xfwm4-theme-tyrex \
207 #  xfwm4-theme-wallis \  
208   xfwm4-themes \
209 "
210
211 XSERVER_BASE = " \
212   ${XSERVER} \
213   dbus-x11 \
214   desktop-file-utils \
215   iso-codes \
216   mime-support \
217   notification-daemon inotify-tools \
218   xauth \
219   xdg-utils \
220   xhost \
221   xinetd \
222   xinit \
223   xlsfonts \
224   xrdb \
225   xrefresh \
226   xset \
227   xvinfo \
228   devilspie \
229   encodings \
230   xterm \
231 "
232
233 RDEPENDS_${PN} = " \
234   task-pandora-core \
235   angstrom-x11-base-depends \
236   ${ANGSTROM_EXTRA_INSTALL} \
237   ${APPS} \
238   ${BLUETOOTH_GUI} \
239   ${IM_CLIENT} \
240   ${DISPMAN} \
241   ${FONTS} \
242   ${GAMES} \  
243   ${GNOME_GTK} \
244   ${GNOME_APPS} \
245   ${GSTREAMER} \
246   ${ICON_THEME} \
247   ${LAUNCHERS} \
248   ${PANDORA} \
249   ${PERL} \
250   ${PULSEAUDIO} \
251   ${QT_SUPPORT} \
252   ${TOTEM} \
253   ${TOUCHSCREEN} \
254   ${XSERVER_BASE} \
255   ${XFCE46_BASE} \
256   ${XFCE46_EXTRAS} \
257   ${XFCE_THEMES} \
258   \
259   rxvt-unicode \
260 #  xst \
261 #  suspend-desktop \
262 #  teleport \
263   gdk-pixbuf-loader-png \
264   gdk-pixbuf-loader-xpm \
265   gdk-pixbuf-loader-jpeg \
266   pango-module-basic-x \
267   pango-module-basic-fc \
268   xcursor-transparent-theme \   
269   xterm xmms \
270   jaaa nmap iperf \
271 #  gnuplot \
272 "