bc86a7ac7bacbbec749e62517f5e879d4ad3b84c
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps and libs in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r20"
9
10 inherit task 
11
12 AUFS = " \
13 #  aufs2-27 \
14   aufs2-util \
15 "
16
17 BLUETOOTH = " \
18   blueprobe \
19   bluez4 gst-plugin-bluez \
20   libsndfile1 libasound-module-bluez \
21 "
22
23 # Package up the boot scripts and bootchart to help us work to drop the startup time.
24 BOOT = " \
25   pandora-uboot-scripts \
26   bootchart \
27 "
28
29 WIRELESS = " \
30   pandora-firmware \
31   wl1251-modules \
32 #  pandora-wifi pandora-wifi-tools \
33   wireless-tools \
34   wpa-supplicant \  
35   networkmanager netm-cli \
36 "
37
38 MEDIA_LIBS = " \
39   libmodplug \
40   libsdl-x11 libsdl-mixer libsdl-image \
41   libsdl-gfx libsdl-net libsdl-ttf \
42   libpng libpng12 libpng3 \
43   faad2 \
44   mikmod \
45   speex \  
46   
47 "
48 OPENGLES = " \
49   omap3-sgx-modules devmem2 \
50   libgles-omap3 \
51   libgles-omap3-rawdemos \
52 "
53
54 PAM = " \
55   libpam \
56   libpam-meta \
57 "
58
59 PANDORA_LIBS = " \
60   pandora-libpnd lsof \
61   omap3-deviceid \
62   pandora-skel \
63 "
64
65 SUDO = " \
66   sudo sudo-enable-wheel-group \ 
67   pandora-sudoers \
68 "
69
70 SSH = " \
71   openssh-scp \
72   openssh-ssh \
73 "
74
75 TOUCHSCREEN = " \
76   tslib tslib-tests tslib-calibrate pointercal \
77 "
78
79 FS_SUPPORT = " \
80 #  nfs-utils \
81   nfs-utils-client \
82   fuse fuse-utils \
83   sshfs-fuse gmailfs curlftpfs \
84   ntfs-3g \
85   squashfs-tools \
86 "
87
88 EXTRA_TOOLS = " \
89   avahi \
90   fbgrab fbset fbset-modes \
91   portmap \
92   file \
93   socat \
94   strace \
95   ksymoops \
96   kexec-tools \
97   zip \        
98   gzip \
99   bash \
100   bzip2 \  
101   minicom \
102   nano \
103   gdb \
104   sessreg \
105 "
106
107 # Add extra util-linux-ng utils to image. 
108 # TODO: Fix util-linux-ng to meta depend on all subpackages.
109 UTIL_LINUX_NG_EXTRAS = " \
110   util-linux-ng-losetup util-linux-ng-mountall \
111   util-linux-ng-swaponoff \
112 "
113   
114 RDEPENDS_${PN} = "\
115   task-base-extended \
116   task-proper-tools \
117   ${AUFS} \
118   ${WIRELESS} \
119   ${BLUETOOTH} \  
120   ${BOOT} \
121   ${MEDIA_LIBS} \
122   ${OPENGLES} \
123   ${PANDORA_LIBS} \
124   ${SSH} \
125   ${SUDO} \
126   ${TOUCHSCREEN} \
127   ${FS_SUPPORT} \
128   ${EXTRA_TOOLS} \
129   ${UTIL_LINUX_NG_EXTRAS} \
130 #        packagekit \
131   python-pygame \
132   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
133   rdesktop \
134   mplayer \
135   \
136 #  angstrom-zeroconf-audio \
137   angstrom-led-config \ 
138   \
139   ${PAM} \
140 "
141
142 # Make sure we install all kernel modules with the Pandora images
143 RRECOMMENDS_${PN} += "kernel-modules"
144
145 PACKAGE_ARCH = "${MACHINE_ARCH}"
146
147 RRECOMMENDS_${PN}_append_armv7a = " \
148 #       gnash gnash-browser-plugin \
149         omapfbplay \
150 "