ad0d2253b983d00a4f7f9332015e852639ab8060
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r6"
9
10 inherit task 
11
12 BLUETOOTH = " \
13   blueprobe \
14   bluez4 gst-plugin-bluez \
15   libsndfile1 libasound-module-bluez \
16 "
17
18 WIRELESS = " \
19   pandora-firmware \
20   wl1251-modules \
21 #  pandora-wifi pandora-wifi-tools \
22   wireless-tools \
23   wpa-supplicant \  
24   networkmanager netm-cli \  
25 "
26
27 OPENGLES = " \
28   omap3-sgx-modules devmem2 \
29   libgles-omap3 libgles-omap3-demos \
30 "
31
32 PAM = " \
33   libpam \
34   libpam-meta \
35 "
36
37 SSH = " \
38   openssh-scp \
39   openssh-ssh \
40 "
41
42 PANDORA_LIBS = " \
43   pandora-libpnd lsof \
44   omap3-deviceid \
45   pandora-skel \
46 "
47
48 TOUCHSCREEN = " \
49   tslib tslib-tests tslib-calibrate pointercal \
50 "
51
52 FS_SUPPORT = " \
53   nfs-utils nfs-utils-client \
54   aufs2-27 aufs2-util \
55   fuse sshfs-fuse ntfs-3g \
56 "
57
58 EXTRA_TOOLS = " \
59   avahi \
60   fbgrab fbset fbset-modes \
61   portmap \
62   file \
63   socat \
64   strace \
65   ksymoops \
66   kexec-tools \
67   zip \        
68   gzip \
69   bash \
70   bzip2 \  
71   sudo sudo-enable-wheel-group \ 
72   minicom \
73   nano \
74 "
75
76 RDEPENDS_${PN} = "\
77   task-base-extended \
78   task-proper-tools \
79   ${WIRELESS} \
80   ${BLUETOOTH} \  
81   ${OPENGLES} \
82   ${PANDORA_LIBS} \
83   ${SSH} \
84   ${TOUCHSCREEN} \
85   ${FS_SUPPORT} \
86   ${EXTRA_TOOLS} \
87 #        packagekit \
88   libsdl-gfx libsdl-net mikmod \
89   python-pygame \
90   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
91   rdesktop \
92   mplayer \
93   \
94   angstrom-zeroconf-audio \
95   angstrom-led-config \ 
96   \
97   ${PAM} \
98 "
99
100 # Make sure we install all kernel modules with the Pandora images
101 RRECOMMENDS_${PN} += "kernel-modules"
102
103 PACKAGE_ARCH = "${MACHINE_ARCH}"
104
105 RRECOMMENDS_${PN}_append_armv7a = " \
106         gnash gnash-browser-plugin \
107         omapfbplay \
108 "