876b19e6be77b17a5c1d4be9d9d21b8829a58ef1
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps and libs in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r22"
9
10 inherit task 
11
12 AUFS = " \
13 #  aufs2-27 \
14   aufs2-util \
15 "
16
17 BLUETOOTH = " \
18   blueprobe \
19   bluez4 gst-plugin-bluez \
20   libsndfile1 libasound-module-bluez \
21 "
22
23 # Package up the boot scripts and bootchart to help us work to drop the startup time.
24 BOOT = " \
25   pandora-uboot-scripts \
26   bootchart \
27   mtd-utils \
28 "
29
30 WIRELESS = " \
31   pandora-firmware \
32   wl1251-modules \
33 #  pandora-wifi pandora-wifi-tools \
34   wireless-tools \
35   wpa-supplicant \  
36   networkmanager netm-cli \
37 "
38
39 MEDIA_LIBS = " \
40   libmodplug \
41   libsdl-x11 libsdl-mixer libsdl-image \
42   libsdl-gfx libsdl-net libsdl-ttf \
43   libpng libpng12 libpng3 \
44   faad2 \
45   mikmod \
46   speex \  
47   
48 "
49 OPENGLES = " \
50   omap3-sgx-modules devmem2 \
51   libgles-omap3 \
52   libgles-omap3-rawdemos \
53 "
54
55 PAM = " \
56   libpam \
57   libpam-meta \
58 "
59
60 PANDORA_LIBS = " \
61   pandora-libpnd lsof \
62   omap3-deviceid \
63   pandora-skel \
64   pandora-lcd-state \
65 "
66
67 SUDO = " \
68   sudo sudo-enable-wheel-group \ 
69   pandora-sudoers \
70 "
71
72 SSH = " \
73   openssh-scp \
74   openssh-ssh \
75 "
76
77 TOUCHSCREEN = " \
78   tslib tslib-tests tslib-calibrate pointercal \
79 "
80
81 FS_SUPPORT = " \
82 #  nfs-utils \
83   nfs-utils-client \
84   fuse fuse-utils \
85   sshfs-fuse gmailfs curlftpfs \
86   ntfs-3g \
87   squashfs-tools \
88 "
89
90 EXTRA_TOOLS = " \
91   avahi \
92   fbgrab fbset fbset-modes \
93   portmap \
94   file \
95   socat \
96   strace \
97   ksymoops \
98   kexec-tools \
99   zip \        
100   gzip \
101   bash \
102   bzip2 \  
103   minicom \
104   nano \
105   gdb \
106   sessreg \
107 "
108
109 # Add extra util-linux-ng utils to image. 
110 # TODO: Fix util-linux-ng to meta depend on all subpackages.
111 UTIL_LINUX_NG_EXTRAS = " \
112   util-linux-ng-losetup util-linux-ng-mountall \
113   util-linux-ng-swaponoff \
114 "
115   
116 RDEPENDS_${PN} = "\
117   task-base-extended \
118   task-proper-tools \
119   ${AUFS} \
120   ${WIRELESS} \
121   ${BLUETOOTH} \  
122   ${BOOT} \
123   ${MEDIA_LIBS} \
124   ${OPENGLES} \
125   ${PANDORA_LIBS} \
126   ${SSH} \
127   ${SUDO} \
128   ${TOUCHSCREEN} \
129   ${FS_SUPPORT} \
130   ${EXTRA_TOOLS} \
131   ${UTIL_LINUX_NG_EXTRAS} \
132 #        packagekit \
133   python-pygame \
134   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
135   rdesktop \
136   mplayer \
137   \
138 #  angstrom-zeroconf-audio \
139   angstrom-led-config \ 
140   \
141   ${PAM} \
142 "
143
144 # Make sure we install all kernel modules with the Pandora images
145 RRECOMMENDS_${PN} += "kernel-modules"
146
147 PACKAGE_ARCH = "${MACHINE_ARCH}"
148
149 RRECOMMENDS_${PN}_append_armv7a = " \
150 #       gnash gnash-browser-plugin \
151         omapfbplay \
152 "