7b507128620efb84c9417527942f2b5055df92b1
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps and libs in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r37"
9
10 inherit task 
11
12 AUFS = " \
13   aufs2-util \
14 "
15
16 BLUETOOTH = " \
17   blueprobe \
18   bluez4 gst-plugin-bluez \
19   libsndfile1 libasound-module-bluez \
20 "
21
22 # Package up the boot scripts and bootchart to help us work to drop the startup time.
23 BOOT = " \
24   pandora-uboot-scripts \
25   bootchart \
26   mtd-utils \
27 "
28
29 # Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
30 BOOST = " \
31   boost \
32 "
33
34 WIRELESS = " \
35   pandora-firmware \
36   wl1251-modules \
37 #  pandora-wifi pandora-wifi-tools \
38   wireless-tools \
39   wpa-supplicant \  
40   networkmanager netm-cli \
41 "
42
43 MEDIA_LIBS = " \
44   libmodplug \
45   libsdl-x11 libsdl-mixer libsdl-image \
46   libsdl-gfx libsdl-net libsdl-ttf \
47   libpng libpng12 libpng3 \
48   faad2 \
49   mikmod \
50   speex \  
51   flac \
52   audiofile \
53 "
54 OPENGLES = " \
55   omap3-sgx-modules devmem2 \
56   libgles-omap3 \
57 #  libgles-omap3-rawdemos \
58 "
59
60 PAM = " \
61   libpam \
62   libpam-meta \
63 "
64
65 PANDORA_LIBS = " \
66   pandora-libpnd lsof \
67   omap3-deviceid \
68   pandora-skel \
69   pandora-state \
70   pandora-usbhost \
71 "
72
73 SUDO = " \
74   sudo sudo-enable-wheel-group \ 
75   pandora-sudoers \
76 "
77
78 SSH = " \
79   openssh-scp \
80   openssh-ssh \
81 "
82
83 TOUCHSCREEN = " \
84   tslib tslib-tests tslib-calibrate pointercal \
85 "
86
87 FS_SUPPORT = " \
88 #  nfs-utils \
89   nfs-utils-client \
90   fuse fuse-utils \
91   sshfs-fuse gmailfs curlftpfs \
92   ntfs-3g \
93   squashfs-tools \
94 "
95
96 EXTRA_TOOLS = " \
97   avahi \
98   fbgrab fbset fbset-modes \
99   portmap \
100   file \
101   socat \
102   strace \
103   screen \
104   rsync \
105   unrar \
106   ksymoops \
107   kexec-tools \
108   zip \        
109   gzip \
110   bash \
111   bzip2 \  
112   minicom \
113   nano \
114   gdb \
115   sessreg \
116   lua5.1 \
117   tzdata \
118 "
119
120 # Add extra util-linux-ng utils to image. 
121 # TODO: Fix util-linux-ng to meta depend on all subpackages.
122 UTIL_LINUX_NG_EXTRAS = " \
123   util-linux-ng-losetup util-linux-ng-mountall \
124   util-linux-ng-swaponoff \
125 "
126   
127 RDEPENDS_${PN} = "\
128   task-base-extended \
129   task-proper-tools \
130   ${AUFS} \
131   ${BOOST} \
132   ${WIRELESS} \
133   ${BLUETOOTH} \  
134   ${BOOT} \
135   ${MEDIA_LIBS} \
136   ${OPENGLES} \
137   ${PANDORA_LIBS} \
138   ${PAM} \  
139   ${SSH} \
140   ${SUDO} \
141   ${TOUCHSCREEN} \
142   ${FS_SUPPORT} \
143   ${EXTRA_TOOLS} \
144   ${UTIL_LINUX_NG_EXTRAS} \
145 #        packagekit \
146   python-pygame \
147   python-misc \
148   python-modules \
149   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
150   rdesktop \
151   \
152 #  angstrom-zeroconf-audio \
153   angstrom-led-config \ 
154   ntpdate \ 
155   omap3-pandora-kernel2 \
156 "
157
158 # Make sure we install all kernel modules with the Pandora images
159 RRECOMMENDS_${PN} += "kernel-modules"
160
161 PACKAGE_ARCH = "${MACHINE_ARCH}"