4640f76f55a1119112318b68fd964dd7e6be69d6
[openpandora.oe.git] / recipes / pandora-system / pandora-wifi_git.bb
1 DESCRIPTION = "Kernel drivers for the TI1251 WiFi chip found on the Pandora - Connected via SDIO"
2 LICENSE = "GPLv2"
3
4 # Check the include for the source location/GIT SRCREV etc.
5 require pandora-wifi.inc
6
7 SRC_URI += " \
8         file://rc.tiwifi \
9         file://0001-Initial-work-on-WEXT-support.patch;patch=1 \
10         file://0002-More-cleanup-work-on-WEXT.-Now-at-the-point-that-use.patch;patch=1 \
11         file://0003-Oooops-now-lets-try-something-that-compiles.patch;patch=1 \
12         file://0004-Clean-up-to-use-IW_RETRY_LONG-and-IW_RETRY_SHORT.patch;patch=1 \
13         file://0005-Fix-ooops-I-really-don-t-want-funky-private-features.patch;patch=1 \
14 "
15
16 inherit update-rc.d
17
18 INITSCRIPT_NAME = "tiwifi-init"
19 INITSCRIPT_PARAMS = "start 30 5 2 . stop 40 0 1 6 ."
20
21 do_compile_prepend() {
22           cd ${S}/sta_dk_4_0_4_32/
23 }
24
25 do_install() {
26           cd ${S}/sta_dk_4_0_4_32/
27           mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/tiwlan
28           cp ${S}/sta_dk_4_0_4_32/*.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/tiwlan
29           install -d ${D}${sysconfdir}/init.d/
30           cp -pP ${WORKDIR}/rc.tiwifi ${D}${sysconfdir}/init.d/tiwifi-init
31           cp -pP ${S}/sta_dk_4_0_4_32/fw/tiwlan.ini ${D}${sysconfdir}/tiwlan.ini         
32 }
33
34 FILES_${PN} += "/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/tiwlan/*.ko.*"