05c8b6f6cde8ba588051d22eaabdd1a614a5812a
[openpandora.oe.git] / recipes / pandora-system / pandora-skel.bb
1 DESCRIPTION = "Default 'new user' files on the OpenPandora."
2
3 COMPATIBLE_MACHINE = "omap3-pandora"
4
5 # /etc/skel is used by Shadow's useradd so you really have that installed for this to make sense ;)
6 RDEPENDS = "shadow"
7
8 PR = "r5"
9
10 SRC_URI = " \
11   file://.xinitrc \     
12   file://bashrc \
13   file://profile \
14   file://mplayconfig \
15   file://pam_environment \ 
16   file://xsettings.xml \
17 "
18
19 # xsettings.xml is a hack until I can figure out why XDG configs are not setting the icon theme for Xfce/GTK+
20
21 do_install() {
22   install -d ${D}${sysconfdir}/skel/
23   install -m 0644 ${WORKDIR}/.xinitrc ${D}${sysconfdir}/skel/.xinitrc
24   install -m 0644 ${WORKDIR}/bashrc ${D}${sysconfdir}/skel/.bashrc
25   install -m 0644 ${WORKDIR}/profile ${D}${sysconfdir}/skel/.profile
26   install -m 0644 ${WORKDIR}/pam_environment ${D}${sysconfdir}/skel/.pam_environment
27   
28   install -d ${D}${sysconfdir}/skel/Applications/Settings/xfce4/xfconf/xfce-perchannel-xml
29   install -m 0644 ${WORKDIR}/xsettings.xml ${D}${sysconfdir}/skel/Applications/Settings/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml
30   
31   install -d ${D}${sysconfdir}/skel/.mplayer/
32   install -m 0644 ${WORKDIR}/mplayconfig ${D}${sysconfdir}/skel/.mplayer/config
33 }
34
35 PACKAGE_ARCH = "${MACHINE_ARCH}"
36
37 FILES_${PN} += "${prefix} ${datadir}"