d30e58aa84f2db90b16b9a345632249373b266bf
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r50"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13           file://op_cpuspeed.sh \
14           file://op_cpuspeed.pnd \          
15           file://op_wifi.sh \
16           file://op_wifi.pnd \  
17           file://op_bluetooth.sh \
18           file://op_bluetooth-check.desktop \
19           file://op_bluetooth.desktop \          
20           file://op_startupmanager.sh \
21           file://op_startupmanager.pnd \
22           file://op_switchgui.sh \
23           file://op_switchgui.pnd \
24           file://startnetbooklauncher \
25           file://startmmenu \    
26           file://startpmenu \ 
27           file://stopmmenu \
28           file://op_calibrate.sh \
29           file://op_calibrate.pnd \
30           file://op_datetime.sh \
31           file://op_datetime.pnd \
32           file://op_usermanager.sh \
33           file://op_usermanager.pnd \
34           file://op_lcdsettings.sh \
35           file://op_lcdsettings.pnd \
36           file://op_lcdrate.sh \
37           file://op_videofir.sh \
38           file://op_storage.sh \
39           file://op_storage.pnd \
40           file://op_nubmode.sh \
41           file://op_nubmode.pnd \
42           file://op_tvout.sh \
43           file://op_tvout.pnd \
44           file://gui.conf \
45           file://cpu.conf \
46           file://gamma.conf \
47           file://service.conf \
48           file://default_up \
49           file://none_up \
50           file://op_env.sh \
51           file://arora.pnd \
52           file://evince.pnd \
53           file://gigolo.pnd \
54           file://midori.pnd \
55           file://mousepad.pnd \
56           file://ristretto.pnd \
57           file://squeeze.pnd \
58           file://thunar.pnd \
59           file://xchat.pnd \
60           file://gcalctool.pnd \
61 "
62
63 do_install() {
64           install -d ${D}${prefix}/pandora/scripts/
65           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
66           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
67           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
68           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
69           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
70           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
71           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
72           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
73           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
74           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
75           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
76           install -m 0755 ${WORKDIR}/op_videofir.sh ${D}${prefix}/pandora/scripts/
77           install -m 0755 ${WORKDIR}/op_nubmode.sh ${D}${prefix}/pandora/scripts/
78           install -m 0755 ${WORKDIR}/op_storage.sh ${D}${prefix}/pandora/scripts/
79           install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
80
81           install -d ${D}${prefix}/pandora/apps/
82           install -m 0755 ${WORKDIR}/op_calibrate.pnd ${D}${prefix}/pandora/apps/
83           install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
84           install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
85           install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
86           install -m 0755 ${WORKDIR}/op_nubmode.pnd ${D}${prefix}/pandora/apps/
87           install -m 0755 ${WORKDIR}/op_startupmanager.pnd ${D}${prefix}/pandora/apps/
88           install -m 0755 ${WORKDIR}/op_storage.pnd ${D}${prefix}/pandora/apps/
89           install -m 0755 ${WORKDIR}/op_switchgui.pnd ${D}${prefix}/pandora/apps/
90           install -m 0755 ${WORKDIR}/op_usermanager.pnd ${D}${prefix}/pandora/apps/
91           install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
92           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
93
94           install -d ${D}${prefix}/pandora/mmenu/
95           install -m 0755 ${WORKDIR}/arora.pnd ${D}${prefix}/pandora/mmenu/
96           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
97           install -m 0755 ${WORKDIR}/gigolo.pnd ${D}${prefix}/pandora/mmenu/
98           install -m 0755 ${WORKDIR}/midori.pnd ${D}${prefix}/pandora/mmenu/
99           install -m 0755 ${WORKDIR}/mousepad.pnd ${D}${prefix}/pandora/mmenu/
100           install -m 0755 ${WORKDIR}/ristretto.pnd ${D}${prefix}/pandora/mmenu/
101           install -m 0755 ${WORKDIR}/squeeze.pnd ${D}${prefix}/pandora/mmenu/
102           install -m 0755 ${WORKDIR}/thunar.pnd ${D}${prefix}/pandora/mmenu/
103           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
104           install -m 0755 ${WORKDIR}/gcalctool.pnd ${D}${prefix}/pandora/mmenu/
105
106           install -d ${D}${datadir}/applications/
107           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
108           
109           install -d ${D}${sysconfdir}/xdg/autostart/
110           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
111
112           install -d ${D}${sysconfdir}/pandora/conf/
113           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
114           install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
115           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
116           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
117
118           install -d ${D}${sysconfdir}/pandora/conf/dss_fir/
119           install -m 0644 ${WORKDIR}/default_up ${D}${sysconfdir}/pandora/conf/dss_fir/
120           install -m 0644 ${WORKDIR}/none_up ${D}${sysconfdir}/pandora/conf/dss_fir/
121
122           install -d ${D}${sysconfdir}/profile.d/
123           install -m 0755 ${WORKDIR}/op_env.sh ${D}${sysconfdir}/profile.d/
124
125           install -d ${D}${bindir}/
126           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
127           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
128           install -m 0755 ${WORKDIR}/startpmenu ${D}${bindir}/
129           install -m 0755 ${WORKDIR}/stopmmenu ${D}${bindir}/
130 }
131
132 PACKAGE_ARCH = "${MACHINE_ARCH}"
133
134 FILES_${PN} += "${prefix} ${datadir}"