4802b2ccdfcd7364f4df0caf157481e84d2910ca
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r112"
10
11 SRC_URI = " \
12           file://op_paths.sh \
13           file://op_bright.sh \
14           file://op_cpuspeed.sh \
15           file://op_cpuspeed.pnd \     
16           file://op_usbhost.sh \
17           file://op_usbhost.pnd \     
18           file://op_sysspeed.sh \
19           file://op_wifi.sh \
20           file://op_wifi.pnd \  
21           file://op_bluetooth.sh \
22           file://op_bluetooth_work.sh \
23           file://op_bluetooth-check.desktop \
24           file://op_bluetooth.desktop \          
25           file://op_startupmanager.sh \
26           file://op_startupmanager.pnd \
27           file://op_switchgui.sh \
28           file://op_switchgui.pnd \
29           file://startnetbooklauncher \
30           file://startmmenu \    
31           file://startpmenu \ 
32           file://stopmmenu \
33           file://op_calibrate.sh \
34           file://op_calibrate.pnd \
35           file://op_datetime.sh \
36           file://op_datetime.pnd \
37           file://op_usermanager.sh \
38           file://op_usermanager.pnd \
39           file://op_lcdsettings.sh \
40           file://op_lcdsettings.pnd \
41           file://op_cpusettings.sh \
42           file://op_cpusettings.pnd \
43           file://op_lcdrate.sh \
44           file://op_videofir.sh \
45           file://op_storage.sh \
46           file://op_storage.pnd \
47           file://op_nubmode.py \
48           file://op_nubmode.pnd \
49           file://op_nubchange.sh \
50           file://op_lidsettings.pnd \
51           file://op_lidsettings.sh \
52           file://op_touchinit.sh \
53           file://op_tvout.sh \
54           file://op_tvout.pnd \
55           file://ConfigModel.py \
56           file://TVoutConfig.py \
57           file://op_inputtest.pnd \
58           file://gui.conf \
59           file://cpu.conf \
60           file://gamma.conf \
61           file://service.conf \
62           file://nub_profiles.conf \
63           file://tvout-profiles.conf \
64           file://nubmode.glade \
65           file://reset_nubs.sh \
66           file://pndlogo.png \
67           file://tvicon.png \
68           file://tvout.glade \
69           file://default_up \
70           file://none_up \
71           file://op_env.sh \
72           file://evince.pnd \
73           file://gigolo.pnd \
74           file://mousepad.pnd \
75           file://ristretto.pnd \
76           file://squeeze.pnd \
77           file://thunar.pnd \
78           file://xchat.pnd \
79           file://gcalctool.pnd \ 
80           file://op_bright_down.sh \ 
81           file://op_lid.sh \  
82           file://op_power.sh \
83           file://op_battlow.sh \ 
84           file://op_bright_up.sh \  
85           file://op_menu.sh \ 
86           file://op_xfcemenu.sh \
87           file://op_hugetlb.sh \
88 "
89
90 do_install() {
91           install -d ${D}${prefix}/pandora/scripts/
92           install -m 0755 ${WORKDIR}/op_paths.sh ${D}${prefix}/pandora/scripts/
93           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
94           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
95           install -m 0755 ${WORKDIR}/op_sysspeed.sh ${D}${prefix}/pandora/scripts/
96           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
97           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
98           install -m 0755 ${WORKDIR}/op_usbhost.sh ${D}${prefix}/pandora/scripts/
99           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
100           install -m 0755 ${WORKDIR}/op_bluetooth_work.sh ${D}${prefix}/pandora/scripts/
101           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
102           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
103           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
104           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
105           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
106           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
107           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
108           install -m 0755 ${WORKDIR}/op_videofir.sh ${D}${prefix}/pandora/scripts/
109           install -m 0755 ${WORKDIR}/op_nubmode.py ${D}${prefix}/pandora/scripts/
110           install -m 0755 ${WORKDIR}/op_nubchange.sh ${D}${prefix}/pandora/scripts/
111           install -m 0755 ${WORKDIR}/op_storage.sh ${D}${prefix}/pandora/scripts/
112           install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
113           install -m 0755 ${WORKDIR}/op_bright_down.sh ${D}${prefix}/pandora/scripts/
114           install -m 0755 ${WORKDIR}/op_lid.sh ${D}${prefix}/pandora/scripts/
115           install -m 0755 ${WORKDIR}/op_power.sh ${D}${prefix}/pandora/scripts/
116           install -m 0755 ${WORKDIR}/op_battlow.sh ${D}${prefix}/pandora/scripts/ 
117           install -m 0755 ${WORKDIR}/op_touchinit.sh ${D}${prefix}/pandora/scripts/ 
118           install -m 0755 ${WORKDIR}/op_bright_up.sh ${D}${prefix}/pandora/scripts/  
119           install -m 0755 ${WORKDIR}/op_menu.sh ${D}${prefix}/pandora/scripts/ 
120           install -m 0755 ${WORKDIR}/op_xfcemenu.sh ${D}${prefix}/pandora/scripts/ 
121           install -m 0755 ${WORKDIR}/op_hugetlb.sh ${D}${prefix}/pandora/scripts/
122           install -m 0755 ${WORKDIR}/reset_nubs.sh ${D}${prefix}/pandora/scripts/ 
123           install -m 0644 ${WORKDIR}/pndlogo.png ${D}${prefix}/pandora/scripts/ 
124           install -m 0755 ${WORKDIR}/ConfigModel.py ${D}${prefix}/pandora/scripts/
125           install -m 0755 ${WORKDIR}/TVoutConfig.py ${D}${prefix}/pandora/scripts/
126           install -m 0644 ${WORKDIR}/tvicon.png ${D}${prefix}/pandora/scripts/ 
127           install -m 0644 ${WORKDIR}/nubmode.glade ${D}${prefix}/pandora/scripts/ 
128           install -m 0644 ${WORKDIR}/tvout.glade ${D}${prefix}/pandora/scripts/ 
129           install -m 0755 ${WORKDIR}/op_lidsettings.sh ${D}${prefix}/pandora/scripts/ 
130
131
132
133           install -d ${D}${prefix}/pandora/apps/
134           install -m 0755 ${WORKDIR}/op_calibrate.pnd ${D}${prefix}/pandora/apps/
135           install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
136           install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
137           install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
138           install -m 0755 ${WORKDIR}/op_cpusettings.pnd ${D}${prefix}/pandora/apps/
139           install -m 0755 ${WORKDIR}/op_nubmode.pnd ${D}${prefix}/pandora/apps/
140           install -m 0755 ${WORKDIR}/op_startupmanager.pnd ${D}${prefix}/pandora/apps/
141           install -m 0755 ${WORKDIR}/op_storage.pnd ${D}${prefix}/pandora/apps/
142           install -m 0755 ${WORKDIR}/op_switchgui.pnd ${D}${prefix}/pandora/apps/
143           install -m 0755 ${WORKDIR}/op_usermanager.pnd ${D}${prefix}/pandora/apps/
144           install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
145           install -m 0755 ${WORKDIR}/op_usbhost.pnd ${D}${prefix}/pandora/apps/
146           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
147           install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
148           install -m 0755 ${WORKDIR}/op_lidsettings.pnd ${D}${prefix}/pandora/apps/
149
150           install -d ${D}${prefix}/pandora/mmenu/
151           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
152           install -m 0755 ${WORKDIR}/gigolo.pnd ${D}${prefix}/pandora/mmenu/
153           install -m 0755 ${WORKDIR}/mousepad.pnd ${D}${prefix}/pandora/mmenu/
154           install -m 0755 ${WORKDIR}/ristretto.pnd ${D}${prefix}/pandora/mmenu/
155           install -m 0755 ${WORKDIR}/squeeze.pnd ${D}${prefix}/pandora/mmenu/
156           install -m 0755 ${WORKDIR}/thunar.pnd ${D}${prefix}/pandora/mmenu/
157           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
158           install -m 0755 ${WORKDIR}/gcalctool.pnd ${D}${prefix}/pandora/mmenu/
159
160           install -d ${D}${datadir}/applications/
161           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
162           
163           install -d ${D}${sysconfdir}/xdg/autostart/
164           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
165
166           install -d ${D}${sysconfdir}/pandora/conf/
167           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
168           install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
169           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
170           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
171           install -m 0666 ${WORKDIR}/nub_profiles.conf ${D}${sysconfdir}/pandora/conf/nub_profiles.conf
172           install -m 0666 ${WORKDIR}/tvout-profiles.conf ${D}${sysconfdir}/pandora/conf/tvout-profiles.conf
173
174           install -d ${D}${sysconfdir}/pandora/conf/dss_fir/
175           install -m 0644 ${WORKDIR}/default_up ${D}${sysconfdir}/pandora/conf/dss_fir/
176           install -m 0644 ${WORKDIR}/none_up ${D}${sysconfdir}/pandora/conf/dss_fir/
177
178           install -d ${D}${sysconfdir}/profile.d/
179           install -m 0755 ${WORKDIR}/op_env.sh ${D}${sysconfdir}/profile.d/
180
181           install -d ${D}${bindir}/
182           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
183           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
184           install -m 0755 ${WORKDIR}/startpmenu ${D}${bindir}/
185           install -m 0755 ${WORKDIR}/stopmmenu ${D}${bindir}/
186 }
187
188 PACKAGE_ARCH = "${MACHINE_ARCH}"
189
190 FILES_${PN} += "${prefix} ${datadir}"