Merge branch 'org.openembedded.dev' of new.openembedded.org:openembedded into org...
authorPhil Blundell <philb@gnu.org>
Thu, 4 Mar 2010 22:51:13 +0000 (22:51 +0000)
committerPhil Blundell <philb@gnu.org>
Thu, 4 Mar 2010 22:51:13 +0000 (22:51 +0000)
recipes/xz/xz-native.inc [new file with mode: 0644]
recipes/xz/xz-native_4.999.9beta.bb [new file with mode: 0644]
recipes/xz/xz-native_git.bb [new file with mode: 0644]
recipes/xz/xz.inc [new file with mode: 0644]
recipes/xz/xz_4.999.9beta.bb [new file with mode: 0644]
recipes/xz/xz_git.bb [new file with mode: 0644]

diff --git a/recipes/xz/xz-native.inc b/recipes/xz/xz-native.inc
new file mode 100644 (file)
index 0000000..bc5e9ff
--- /dev/null
@@ -0,0 +1,2 @@
+inherit native
+require xz_${PV}.bb
diff --git a/recipes/xz/xz-native_4.999.9beta.bb b/recipes/xz/xz-native_4.999.9beta.bb
new file mode 100644 (file)
index 0000000..c4f0da9
--- /dev/null
@@ -0,0 +1,3 @@
+PV = "4.999.9beta"
+
+require xz-native.inc
diff --git a/recipes/xz/xz-native_git.bb b/recipes/xz/xz-native_git.bb
new file mode 100644 (file)
index 0000000..006b9d7
--- /dev/null
@@ -0,0 +1,7 @@
+# XZ_BASE should be the latest released version of xz.
+# It can be set in the distro file.
+#XZ_BASE ?= "4.999.9"
+#SRCREV = "HEAD"
+#PV = "${XZ_BASE}+gitr${SRCREV}"
+PV = "git"
+require xz-native.inc
diff --git a/recipes/xz/xz.inc b/recipes/xz/xz.inc
new file mode 100644 (file)
index 0000000..f103e68
--- /dev/null
@@ -0,0 +1,8 @@
+DESCRIPTION = "XZ Utils is free general-purpose data compression software with high compression ratio.  XZ Utils are the successor to LZMA Utils."
+SECTION = "console/utils"
+LICENSE = "Public Domain"
+INC_PR = "r0"
+S ?= "${WORKDIR}/xz-${PV}"
+#FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/xz-${PV}"
+
+inherit autotools
diff --git a/recipes/xz/xz_4.999.9beta.bb b/recipes/xz/xz_4.999.9beta.bb
new file mode 100644 (file)
index 0000000..4f0adf9
--- /dev/null
@@ -0,0 +1,8 @@
+PV = "4.999.9beta"
+
+require xz.inc
+PR = "${INC_PR}.0"
+SRC_URI = "http://tukaani.org/xz/xz-${PV}.tar.bz2;name=xz"
+SRC_URI[xz.md5sum] = "cc4044fcc073b8bcf3164d1d0df82161"
+SRC_URI[xz.sha256sum] = "330312c4397608d8b7be362cc7edbfeafa6101614bc2164d816ea767656aa15c"
+EXTRA_OECONF = "--enable-shared"
diff --git a/recipes/xz/xz_git.bb b/recipes/xz/xz_git.bb
new file mode 100644 (file)
index 0000000..6c481ed
--- /dev/null
@@ -0,0 +1,22 @@
+# XZ_BASE should be the latest released version of xz.
+# It can be set in the distro file.
+#XZ_BASE ?= "4.999.9"
+#SRCREV = "HEAD"
+#PV = "${XZ_BASE}+gitr${SRCREV}"
+S = "${WORKDIR}/git"
+PV = "git"
+PR = "${INC_PR}.0"
+SRC_URI = "git://ctrl.tukaani.org/xz.git;branch=master;protocol=git"
+EXTRA_OECONF = "--enable-shared --disable-nls"
+DEFAULT_PREFERENCE = "-1"
+require xz.inc
+inherit gettext
+EXTRA_AUTORECONF = "--install"
+# XXX: Not sure what i managed to break, but this should not be needed!
+# | configure.ac:460: required file `build-aux/config.rpath' not found
+do_configure () {
+       install -D -m0755 ${STAGING_DATADIR}/gettext/config.rpath \
+                ${S}/build-aux/config.rpath
+       autotools_do_configure
+}
+# just disabled nls for now