matchbox-session: simple provider of Matchbox session for X11 startup
authorMarcin Juszkiewicz <hrw@koansoftware.com>
Fri, 28 Aug 2009 16:38:53 +0000 (18:38 +0200)
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Fri, 28 Aug 2009 16:45:25 +0000 (18:45 +0200)
In GPE images we use gpe-session-scripts to provide Xsession init
scripts for launching Matchbox components. But what if someone do not
want GPE but want Matchbox?

Poky has it cleaned in other way.

recipes/matchbox-session/matchbox-session.bb [new file with mode: 0644]

diff --git a/recipes/matchbox-session/matchbox-session.bb b/recipes/matchbox-session/matchbox-session.bb
new file mode 100644 (file)
index 0000000..c9014f9
--- /dev/null
@@ -0,0 +1,14 @@
+DESCRIPTION = "Matchbox session support"
+RDEPENDS = "matchbox-common"
+# they do the same in other way
+RCONFLICTS = "gpe-session-scripts"
+
+do_install() {
+        install -d ${D}${sysconfdir}/X11/Xsession.d/
+        ln -sf ${bindir}/matchbox-session ${D}${sysconfdir}/X11/Xsession.d/90matchbox-session
+}
+
+PACKAGE_ARCH = "all"
+PACKAGES = "${PN}"
+
+FILES_${PN} = "${sysconfdir}"