gpe-tetris: Fix install: don't di install -s
authorSteve Sakoman <steve@sakoman.com>
Fri, 8 May 2009 16:24:47 +0000 (18:24 +0200)
committerFlorian Boor <florian.boor@kernelconcepts.de>
Fri, 8 May 2009 16:33:26 +0000 (18:33 +0200)
recipes/gpe-tetris/gpe-tetris-0.6-4/fix-install.patch [new file with mode: 0644]
recipes/gpe-tetris/gpe-tetris_0.6-4.bb

diff --git a/recipes/gpe-tetris/gpe-tetris-0.6-4/fix-install.patch b/recipes/gpe-tetris/gpe-tetris-0.6-4/fix-install.patch
new file mode 100644 (file)
index 0000000..2e32aa5
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git gpe-tetris-0.6-4/Makefile-orig gpe-tetris-0.6-4/Makefile
+index 82c7245..27de49f 100644
+--- gpe-tetris-0.6-4/Makefile-orig
++++ gpe-tetris-0.6-4/Makefile
+@@ -46,7 +46,7 @@ install-program: all
+       install -m 644 pixmaps/stop.png $(DESTDIR)$(PREFIX)/share/gpe/pixmaps/default/tetris/stop.png
+       install -m 644 pixmaps/pause.png $(DESTDIR)$(PREFIX)/share/gpe/pixmaps/default/tetris/pause.png
+       install -m 644 pixmaps/highscores.png $(DESTDIR)$(PREFIX)/share/gpe/pixmaps/default/tetris/highscores.png
+-      install -s $(PACKAGE) $(BIN_PATH)/$(PACKAGE)
++      install $(PACKAGE) $(BIN_PATH)/$(PACKAGE)
+       install -d $(DESTDIR)$(PREFIX)/share/applications
+       install -d $(DESTDIR)$(PREFIX)/share/pixmaps
+       install -m 644 gpe-tetris.desktop $(DESTDIR)$(PREFIX)/share/applications/
index 4a13d24..aa33b1f 100644 (file)
@@ -1,9 +1,11 @@
 LICENSE = "GPL"
 inherit gpe
+PR = "r1"
+
 
 DESCRIPTION = "GTK+2 port of the well known game, Tetris."
 DEPENDS = "gtk+ libgpewidget gpe-icons"
 SECTION = "gpe"
 PRIORITY = "optional"
 
-
+SRC_URI += "file://fix-install.patch;patch=1"