glib-2.0: update to 2.42.0
authorGrazvydas Ignotas <notasas@gmail.com>
Thu, 9 Oct 2014 22:31:21 +0000 (01:31 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Thu, 9 Oct 2014 22:31:21 +0000 (01:31 +0300)
conf/distro/include/angstrom-2008-preferred-versions.inc
recipes/glib-2.0/glib-2.0/properties_deprecation.patch [new file with mode: 0644]
recipes/glib-2.0/glib-2.0_2.42.0.bb [new file with mode: 0644]

index b7315ab..de56845 100644 (file)
@@ -8,9 +8,9 @@ PREFERRED_VERSION_cairo         = "1.12.16"
 PREFERRED_VERSION_dbus                 = "1.2.22"
 PREFERRED_VERSION_dropbear      = "0.51"
 PREFERRED_VERSION_fontconfig   = "2.8.0"
-PREFERRED_VERSION_glib-2.0     = "2.40.2"
-PREFERRED_VERSION_glib-2.0-native = "2.40.2"
-PREFERRED_VERSION_glibmm = "2.40.2"
+PREFERRED_VERSION_glib-2.0     = "2.42.0"
+PREFERRED_VERSION_glib-2.0-native = "2.42.0"
+PREFERRED_VERSION_glibmm = "2.42.0"
 PREFERRED_VERSION_gst-pulse    = "0.9.7"
 PREFERRED_VERSION_gtk+         = "2.24.24"
 PREFERRED_VERSION_gtk+-native  = "2.24.24"
diff --git a/recipes/glib-2.0/glib-2.0/properties_deprecation.patch b/recipes/glib-2.0/glib-2.0/properties_deprecation.patch
new file mode 100644 (file)
index 0000000..0088be0
--- /dev/null
@@ -0,0 +1,26 @@
+From b12bd1c3dcfbb398d2462dcf584a1f6d5173ca9a Mon Sep 17 00:00:00 2001
+From: Ryan Lortie <desrt@desrt.ca>
+Date: Thu, 25 Sep 2014 17:18:22 -0400
+Subject: properties: disable default deprecation warnings
+
+Disable the deprecation warnings on GObject properties by default.  This
+change is only being made on the stable branch, and maybe only for this
+one stable series -- the warnings will remain enabled by default on the
+unstable releases.
+
+diff --git a/gobject/gobject.c b/gobject/gobject.c
+index cd00244..b013c12 100644
+--- a/gobject/gobject.c
++++ b/gobject/gobject.c
+@@ -1311,7 +1311,7 @@ consider_issuing_property_deprecation_warning (const GParamSpec *pspec)
+       const gchar *value = g_getenv ("G_ENABLE_DIAGNOSTIC");
+       if (!value)
+-        value = "-";
++        value = "0";
+       g_once_init_leave (&enable_diagnostic, value);
+     }
+-- 
+cgit v0.10.1
+
diff --git a/recipes/glib-2.0/glib-2.0_2.42.0.bb b/recipes/glib-2.0/glib-2.0_2.42.0.bb
new file mode 100644 (file)
index 0000000..1246fce
--- /dev/null
@@ -0,0 +1,99 @@
+DESCRIPTION = "GLib is a general-purpose utility library, \
+which provides many useful data types, macros, \
+type conversions, string utilities, file utilities, a main \
+loop abstraction, and so on. It works on many \
+UNIX-like platforms, Windows, OS/2 and BeOS."
+LICENSE = "LGPLv2+"
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r2"
+DEPENDS += "glib-2.0-native virtual/libiconv zlib"
+DEPENDS += "libffi python-argparse-native zlib"
+DEPENDS_virtclass-native += "pkgconfig-native gettext-native libffi-native zlib-native"
+DEPENDS_virtclass-nativesdk += "nativesdk-libtool nativesdk-gettext nativesdk-libffi nativesdk-zlib ${BPN}-native"
+
+SRC_URI = "\
+           http://ftp.gnome.org/pub/GNOME/sources/glib/2.42/glib-${PV}.tar.xz \
+           file://configure-libtool.patch;patch=1 \
+           file://fix-conflicting-rand.patch;patch=1 \
+           file://add-march-i486-into-CFLAGS-automatically.patch;patch=1 \
+           file://glib-2.0-configure-readlink.patch;patch=1 \
+           file://uclibc.patch;patch=1 \
+           file://0001-configure.ac-Do-not-use-readlink-when-cross-compilin.patch;patch=1 \
+           file://allow-run-media-sdX-drive-mount-if-username-root.patch;patch=1 \
+           file://properties_deprecation.patch;patch=1 \
+"
+
+SRC_URI[md5sum] = "71af99768063ac24033ac738e2832740"
+SRC_URI[sha256sum] = "94fbc0a7d10633433ff383e540607de649c1b46baaa59dea446a50977a6c4472"
+
+inherit autotools gettext gtk-doc pkgconfig
+
+S = "${WORKDIR}/glib-${PV}"
+
+EXTRA_OECONF = "--disable-dtrace --disable-fam --disable-libelf --disable-systemtap --disable-man --enable-included-printf=no --disable-modular-tests --disable-selinux"
+
+do_configure_prepend() {
+       sed -i -e '1s,#!.*,#!${USRBINPATH}/env python,' ${S}/gio/gdbus-2.0/codegen/gdbus-codegen.in
+}
+
+ARM_INSTRUCTION_SET = "arm"
+USE_NLS = "yes"
+
+do_install_append() {
+  if [ "${PN}" != "glib-2.0-native" ]; then
+    sed ${D}${bindir}/gtester-report -i -e 's,${STAGING_BINDIR_NATIVE},${bindir},g'
+  fi
+
+  # remove some unpackaged files
+  rm -f ${D}${libdir}/gdbus-2.0/codegen/*.pyc
+  rm -f ${D}${libdir}/gdbus-2.0/codegen/*.pyo
+  # and empty dirs
+  rm -rf ${D}${libdir}/gio
+
+  # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
+  # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
+  if [ -f ${D}${bindir}/glib-mkenums ]; then
+    sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/glib-mkenums
+  fi
+}
+
+EXTRA_OECONF_virtclass-native = "--disable-dtrace --disable-systemtap"
+
+do_configure_prepend_virtclass-native() {
+    if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
+                echo "${TARGET_SYS}-libtool already present"
+    else
+        cp ${STAGING_BINDIR}/${TARGET_SYS}-libtool ${S}
+    fi
+
+}
+
+#BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
+
+PACKAGES =+ "gobject-2.0 gmodule-2.0 gthread-2.0 gio-2.0 glib-2.0-utils ${PN}-bash-completion ${PN}-codegen"
+LEAD_SONAME = "libglib-2.0.*"
+FILES_${PN}-utils = "${bindir}/* ${datadir}/glib-2.0/gettext"
+FILES_${PN} = "${libdir}/lib*so.* ${libdir}/gio/modules/*.so \
+               ${datadir}/glib-2.0/schemas \
+               ${datadir}/glib-2.0/gettext/mkinstalldirs ${datadir}/glib-2.0/gettext/po/Makefile.in.in"
+FILES_${PN}-dev += "${libdir}/glib-2.0/include \
+                    ${libdir}/gio/modules/*.la"
+FILES_${PN}-dbg += "${datadir}/glib-2.0/gdb ${datadir}/gdb \
+                    ${libdir}/gio/modules/.debug"
+
+FILES_gmodule-2.0 = "${libdir}/libgmodule-2.0.so.*"
+FILES_gobject-2.0 = "${libdir}/libgobject-2.0.so.*"
+FILES_gio-2.0 = "${libdir}/libgio-2.0.so.*"
+FILES_gthread-2.0 = "${libdir}/libgthread-2.0.so.*"
+FILES_${PN}-codegen = "${libdir}/gdbus-2.0/codegen/*.py"
+FILES_${PN}-bash-completion = "${sysconfdir}/bash_completion.d \
+                               ${datadir}/bash-completion"
+
+# Let various glib components end up in glib package
+# for compatibility (with binary packages from Maemo).
+FILES_gthread-2.0_chinook-compat = ""
+FILES_gmodule-2.0_chinook-compat = ""
+FILES_gobject-2.0_chinook-compat = ""
+FILES_gio-2.0_chinook-compat = ""