ecore: convert BBCLASSEXTEND
authorMartin Jansa <Martin.Jansa@gmail.com>
Thu, 11 Mar 2010 09:25:44 +0000 (10:25 +0100)
committerMartin Jansa <Martin.Jansa@gmail.com>
Fri, 19 Mar 2010 19:34:51 +0000 (20:34 +0100)
* different EXTRA_OECONF weren't used for -native as the diff seems
  rather unintentional when OECONF was updated only in non-native
  version, feel free to add it if really needed

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
recipes/efl1/ecore-native_svn.bb [deleted file]
recipes/efl1/ecore.inc
recipes/efl1/ecore_svn.bb

diff --git a/recipes/efl1/ecore-native_svn.bb b/recipes/efl1/ecore-native_svn.bb
deleted file mode 100644 (file)
index 7963574..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-require ecore.inc
-inherit native
-DEPENDS = "eet-native evas-native"
-PR = "r4"
-
-EXTRA_OECONF = "\
-                --enable-ecore-txt \
-                --enable-ecore-config \
-                --disable-ecore-x-xcb \
-                --disable-ecore-x \
-                --enable-ecore-job \
-                --disable-ecore-directfb \
-                --disable-ecore-sdl \
-                --enable-ecore-fb \
-                --enable-ecore-evas \
-                --enable-ecore-evas-fb \
-                --disable-ecore-evas-x11-gl \
-                --disable-ecore-evas-xrender \
-                --disable-ecore-evas-dfb \
-                --disable-ecore-evas-sdl \
-                --disable-openssl \
-                --enable-abstract-sockets \
-                --enable-ecore-con \
-                --enable-ecore-ipc \
-                --enable-ecore-file \
-                --enable-inotify \
-                --disable-poll \
-                --disable-curl \
-                --disable-ecore-desktop \
-                --disable-ecore-imf \
-                --disable-ecore-imf_evas \
-"
index 69d3f76..183f252 100644 (file)
@@ -1,14 +1,17 @@
 DESCRIPTION = "Ecore is the Enlightenment application framework library"
 LICENSE = "MIT BSD"
-DEPENDS = "gettext-native virtual/libiconv curl eet evas tslib glib-2.0 \
+DEPENDS = "gettext-native virtual/libiconv tslib curl eet evas glib-2.0 \
            libxtst libxcomposite libxinerama libxscrnsaver libxdamage libxrandr libxcursor libxprintutil"
+DEPENDS_virtclass-native = "eet-native evas-native"       
 # optional
 # DEPENDS += "directfb libsdl-x11 openssl virtual/libiconv"
 PV = "0.9.9.060+svnr${SRCPV}"
-PR = "r4"
+PR = "r5"
 
 inherit efl
 
+BBCLASSEXTEND = "native"
+
 SRC_URI += "file://fix-ecore-fb-initialization.patch;patch=1"
 
 do_configure_prepend() {
index e3fdf58..5262c0c 100644 (file)
@@ -35,3 +35,13 @@ EXTRA_OECONF = "\
   --disable-openssl \
   --disable-poll \
 "
+
+# List of options which were different in ecore-native, 
+# I know it's SCM, but with missing -native.bb is much easier to check here
+#EXTRA_OECONF_virtclass-native = "\
+#                --disable-ecore-x \
+#                --enable-ecore-evas-fb \
+#                --disable-ecore-evas-x11-gl \
+#                --disable-curl \
+#                --disable-ecore-imf \
+#                --disable-ecore-imf_evas \