packages/ffmpeg/ffmpeg_0.4.9-pre1.bb : Disable mmx for x86
authorStelios Koroneos <skoroneos@digital-opsis.com>
Sun, 24 Aug 2008 10:15:33 +0000 (10:15 +0000)
committerStelios Koroneos <skoroneos@digital-opsis.com>
Sun, 24 Aug 2008 10:15:33 +0000 (10:15 +0000)
Add core-utils to the depends list as build fails during ffmpeg's install/stip stage

packages/ffmpeg/ffmpeg.inc
packages/ffmpeg/ffmpeg_0.4.9-pre1.bb

index aab2c62..6316b4e 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "libs"
 PRIORITY = "optional"
 LICENSE = "LGPL"
 
-DEPENDS = "zlib libogg libvorbis faac faad2 liba52 lame"
+DEPENDS = "coreutils-native zlib libogg libvorbis faac faad2 liba52 lame"
 RSUGGESTS = "mplayer"
 
 inherit autotools pkgconfig
index 6df6d89..f2d5a92 100644 (file)
@@ -1,11 +1,13 @@
 require ffmpeg.inc
 
-PR = "r3"
+PR = "r5"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/ffmpeg/ffmpeg-${PV}.tar.gz \
            file://configure.patch;patch=0 \
            file://gcc4.patch;patch=1 \
            file://soname.patch;patch=1 \
+           file://libavformat-makefile.patch;patch=1 \
+           file://Makefile-lame.patch;patch=1 \
           "
 
 EXTRA_OECONF += " \
@@ -27,13 +29,18 @@ EXTRA_OECONF += " \
         \
         --cpu=${TARGET_ARCH} \
         --tune=${PACKAGE_ARCH} \
-        --extra-ldflags="-la52" \
+        --extra-libs="-la52" \
+        --extra-ldflags="-L${STAGING_LIBDIR}" \
         \
         --disable-audio-beos \
         --disable-v4l \
         --disable-dv1394 \
 "
 
+EXTRA_OECONF_append_x86 += " \
+        --disable-mmx \
+"
+
 do_stage() {
         oe_libinstall -a -so -C libavcodec  libavcodec ${STAGING_LIBDIR}
         oe_libinstall -a -so -C libavformat libavformat ${STAGING_LIBDIR}