enlightenment: bump SRCREV
authorKoen Kooi <koen@openembedded.org>
Thu, 24 Sep 2009 12:51:07 +0000 (14:51 +0200)
committerKoen Kooi <koen@openembedded.org>
Thu, 24 Sep 2009 12:51:07 +0000 (14:51 +0200)
* runtime tested on angstrom/beagleboard
* upgrade paths intact and working

classes/e.bbclass
classes/efl.bbclass
conf/distro/include/sane-srcrevs.inc
recipes/e17/e-wm_svn.bb
recipes/efl1/ecore.inc
recipes/efl1/edje-native_svn.bb
recipes/efl1/edje_svn.bb

index a56cdff..a6fa1d0 100644 (file)
@@ -21,7 +21,9 @@ do_configure_append() {
 export CURL_CONFIG = "${STAGING_BINDIR_CROSS}/curl-config"
 export FREETYPE_CONFIG = "${STAGING_BINDIR_CROSS}/freetype-config"
 
-PACKAGES = "${PN}-dbg ${PN}-themes ${PN} ${PN}-dev ${PN}-lib"
+# This construction is stupid, someone with more E knowledge should change it to =+ or something
+# And it's in efl.bbclass as well....
+PACKAGES = "${PN}-dbg ${PN}-themes ${PN} ${PN}-dev ${PN}-doc ${PN}-lib"
 FILES_${PN}-lib = "${libdir}/lib*.so.*"
 FILES_${PN}-themes = "${datadir}/${PN}/themes ${datadir}/${PN}/data ${datadir}/${PN}/fonts ${datadir}/${PN}/pointers ${datadir}/${PN}/images ${datadir}/${PN}/users ${datadir}/${PN}/images ${datadir}/${PN}/styles"
 FILES_${PN}-dev += "${includedir} ${libdir}/lib*.so"
index 9d24a0f..22e664c 100644 (file)
@@ -23,7 +23,8 @@ do_stage() {
        autotools_stage_all
 }
 
-PACKAGES = "${PN}-dbg ${PN} ${PN}-themes ${PN}-dev ${PN}-tests"
+# This construction is stupid, someone with more E knowledge should change it to =+ or something
+PACKAGES = "${PN}-dbg ${PN} ${PN}-themes ${PN}-dev ${PN}-doc ${PN}-tests"
 
 FILES_${PN} = "${libdir}/*.so.*"
 
index 00273b2..77acd4f 100644 (file)
@@ -248,7 +248,7 @@ SRCREV_pn-xserver-kdrive-glamo ?= "9b28d998424c77fbc057dd3a022ccbb122793a52"
 # Enlightenment Foundation Libraries
 # Caution: This is not alphabetically, but (roughly) dependency-sorted.
 # Please leave it like that.
-EFL_SRCREV ?= "41533"
+EFL_SRCREV ?= "42645"
 SRCREV_pn-edb-native ?= "${EFL_SRCREV}"
 SRCREV_pn-edb ?= "${EFL_SRCREV}"
 SRCREV_pn-eina-native ?= "${EFL_SRCREV}"
index 7eac096..97426fb 100644 (file)
@@ -107,6 +107,7 @@ FILES_${PN} = "\
   ${libdir}/enlightenment/utils/* \
   ${libdir}/enlightenment/modules/*/*.* \
   ${libdir}/enlightenment/modules/*/*/* \
+  ${libdir}/enlightenment/*plugins/*/*/* \
   ${libdir}/enlightenment/preload/e_precache.so \
   ${datadir}/locale \
   ${datadir}/enlightenment/data/icons \
@@ -152,13 +153,14 @@ FILES_${PN}-dbg += "\
   ${libdir}/enlightenment/modules/*/*/.debug/ \
   ${libdir}/enlightenment/preload/.debug/ \
   ${libdir}/enlightenment/utils/.debug/ \
+  ${libdir}/enlightenment/*plugins/*/*/.debug \
 "
 
 FILES_${PN}-doc += "\
   ${datadir}/enlightenment/doc \
 "
 
-CONFFILES_${PN} = "/etc/xdg/menus/applications.menu"
+CONFFILES_${PN} = "${sysconfdir}/xdg/menus/applications.menu"
 
 ALTERNATIVE_PATH = "${bindir}/enlightenment_start.oe"
 ALTERNATIVE_NAME = "x-window-manager"
index facd7a2..0ebddd5 100644 (file)
@@ -8,6 +8,11 @@ PR = "r3"
 
 inherit efl
 
+do_configure_prepend() {
+       touch ${S}/po/Makefile.in.in || true
+       sed -i -e 's: po::g' ${S}/Makefile.am
+}
+
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/ecore"
 
 PACKAGES =+ "\
index e7650cd..7b4b79a 100644 (file)
@@ -2,7 +2,7 @@ require edje_${PV}.bb
 inherit native
 PR = "r3"
 
-DEPENDS = "evas-native ecore-native eet-native embryo-native"
+DEPENDS = "lua5.1-native evas-native ecore-native eet-native embryo-native"
 
 do_configure_prepend() {
        sed -i 's:EMBRYO_PREFIX"/bin:"${STAGING_BINDIR}:' ${S}/src/bin/edje_cc_out.c
index 7f94b08..bfd00ec 100644 (file)
@@ -1,11 +1,22 @@
 DESCRIPTION = "Edje is the Enlightenment graphical design & layout library"
-DEPENDS = "eet evas ecore embryo edje-native"
+DEPENDS = "lua5.1 eet evas ecore embryo edje-native"
 LICENSE = "MIT BSD"
 PV = "0.9.92.060+svnr${SRCREV}"
 PR = "r4"
 
 inherit efl
 
+# The new lua stuff is a bit broken...
+do_configure_append() {
+       for i in $(find "${S}" -name "Makefile") ; do
+               sed -i -e 's:-L/usr/local/lib::g'  $i
+       done
+}
+
+do_compile_append() {
+       sed -i -e s:local/::g -e 's:-L${STAGING_LIBDIR}::g' ${S}/edje.pc
+}
+
 # gain some extra performance at the expense of RAM - generally i'd say bad
 # and a possible source of bugs
 #EXTRA_OECONF = "--enable-edje-program-cache"