mingw-gcc, mingw-runtime, mingw-w32api: Fix DEFAULT_PREFERENCES to be correct
authorTom Rini <trini@embeddedalley.com>
Fri, 17 Apr 2009 20:06:09 +0000 (13:06 -0700)
committerTom Rini <trini@embeddedalley.com>
Fri, 17 Apr 2009 21:38:50 +0000 (14:38 -0700)
We want a default of -1 (not 0) and 1 for "mingw32" so that the default list
of overrides will catch and use them.

recipes/gcc/mingw-gcc_3.4.5-20060117-2.bb
recipes/mingw/mingw-runtime.inc
recipes/mingw/mingw-w32api.inc

index 22f9170..fd45e9f 100644 (file)
@@ -4,8 +4,8 @@ HOMEPAGE = "http://www.mingw.org/"
 SECTION = "devel"
 LICENSE = "GPL"
 
-DEFAULT_PREFERENCE = "0"
-DEFAULT_PREFERENCE_sdk-mingw32 = "1"
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_mingw32 = "1"
 
 inherit autotools gettext
 
index d984911..5820e99 100644 (file)
@@ -5,8 +5,8 @@ DEPENDS = "virtual/${TARGET_PREFIX}gcc-initial mingw-w32api"
 
 PROVIDES = "virtual/${TARGET_PREFIX}libc virtual/${TARGET_PREFIX}libc-for-gcc"
 
-DEFAULT_PREFERENCE = "0"
-DEFAULT_PREFERENCE_sdk-mingw32 = "1"
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_mingw32 = "1"
 
 PACKAGES = ""
 
index ecb1cd2..ac2ede9 100644 (file)
@@ -5,8 +5,8 @@ DEPENDS = "virtual/${TARGET_PREFIX}gcc-initial"
 
 PROVIDES = "mingw-w32api"
 
-DEFAULT_PREFERENCE = "0"
-DEFAULT_PREFERENCE_sdk-mingw32 = "1"
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_mingw32 = "1"
 
 PACKAGES = ""