dt: convert to .inc, add no_aio patch for uclibc
authorTom Rini <tom_rini@mentor.com>
Fri, 19 Feb 2010 19:08:00 +0000 (12:08 -0700)
committerChris Larson <chris_larson@mentor.com>
Fri, 19 Feb 2010 19:10:59 +0000 (12:10 -0700)
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Signed-off-by: Chris Larson <chris_larson@mentor.com>
recipes/dt/dt.inc [new file with mode: 0644]
recipes/dt/dt_15.14.bb
recipes/dt/files/no_aio.patch [new file with mode: 0644]

diff --git a/recipes/dt/dt.inc b/recipes/dt/dt.inc
new file mode 100644 (file)
index 0000000..7e64bc5
--- /dev/null
@@ -0,0 +1,16 @@
+DESCRIPTION = "The Data Test Program (dt) is a generic data test program used to verify proper \
+operation of peripherals, file systems, device drivers, or any data stream supported by the \
+operating system."
+SECTION = "console/tests"
+HOMEPAGE = "http://home.comcast.net/~SCSIguy/SCSI_FAQ/RMiller_Tools/dt.html"
+LICENSE = "Public domain"
+INC_PR = "r0"
+
+SRC_URI = "http://home.comcast.net/~SCSIguy/SCSI_FAQ/RMiller_Tools/ftp/dt/dt-source.tar.gz"
+S = "${WORKDIR}/dt.d-WIP"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_compile() {
+       ${MAKE} -f Makefile.linux
+}
index 5185af4..346b312 100644 (file)
@@ -1,16 +1,9 @@
-DESCRIPTION = "The Data Test Program (dt) is a generic data test program used to verify proper \
-operation of peripherals, file systems, device drivers, or any data stream supported by the \
-operating system."
-SECTION = "console/tests"
-HOMEPAGE = "http://home.comcast.net/~SCSIguy/SCSI_FAQ/RMiller_Tools/dt.html"
-LICENSE = "Public domain"
+require dt.inc
 
-SRC_URI = "http://home.comcast.net/~SCSIguy/SCSI_FAQ/RMiller_Tools/ftp/dt/dt-source.tar.gz"
-S = "${WORKDIR}/${PN}.d-WIP"
+PR = "${INC_PR}.1"
 
-do_compile() {
-       ${MAKE} -f Makefile.linux
-}
+SRC_URI_append_linux-uclibc = " file://no_aio.patch;patch=1 "
+SRC_URI_append_linux-uclibcgnueabi = " file://no_aio.patch;patch=1 "
 
 do_install() {
        install -d ${D}${bindir}
diff --git a/recipes/dt/files/no_aio.patch b/recipes/dt/files/no_aio.patch
new file mode 100644 (file)
index 0000000..4b65d89
--- /dev/null
@@ -0,0 +1,17 @@
+---
+ Makefile.linux |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: dt.d-WIP/Makefile.linux
+===================================================================
+--- dt.d-WIP/Makefile.linux
++++ dt.d-WIP/Makefile.linux
+@@ -68,7 +68,7 @@ LINTLIBS=
+ PORG      = -O3
+-CFLAGS= $(PORG) -DAIO -DFIFO -DMMAP -DTTY -D__linux__ -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++CFLAGS= $(PORG) -DFIFO -DMMAP -DTTY -D__linux__ -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ CPP=  /lib/cpp
+ CPPOPTS= -D__GNUC__ -DFIFO -DMMAP -D__linux__ -D_GNU_SOURCE
+ LDFLAGS=