Merge branch 'org.openembedded.dev' of git://git.openembedded.org/openembedded into...
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Fri, 10 Jul 2009 10:22:58 +0000 (14:22 +0400)
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Fri, 10 Jul 2009 10:22:58 +0000 (14:22 +0400)
conf/checksums.ini
conf/distro/include/slugos.inc
recipes/gnuradio/gnuradio_3.2.1.bb [new file with mode: 0644]

index 660aa5a..26c217a 100644 (file)
@@ -8606,6 +8606,10 @@ sha256=f215b31c55da6f6111ab473565689eb3d0e23523a20a889efefe5ac612a8ceeb
 md5=c1eb3de26b67ddc08a61a7c2fc636203
 sha256=36480bce862b6d424f4b34bbfeed838b80bcbb484602dee43c412a7d0dc4b42b
 
+[ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.1.tar.gz]
+md5=f0721c5dce7cb02c75ac4e7bb9cc0ec9
+sha256=a12b0fcd08508a85ee7ec7003ec0f3418378d479304ce85e8453d46bacc0ce9f
+
 [ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.tar.gz]
 md5=9d91d0f8f2cb35bc86435784fa8e72d8
 sha256=a780490056b1f1f95c7bf91e175773e00f4be23e1b7e5147ccd507b6f32097af
index fb036c1..903e5ed 100644 (file)
@@ -127,9 +127,11 @@ PREFERRED_PROVIDER_virtual/arm-linux-binutils                  = "binutils-cross"
 PREFERRED_PROVIDER_virtual/armeb-linux-binutils                    = "binutils-cross"
 PREFERRED_PROVIDER_linux-libc-headers                      = "linux-libc-headers"
 
-# Select the smallest provider of x11 libraries
-PREFERRED_PROVIDER_virtual/libx11              = "diet-x11"
-SRCDATE_diet-x11                               ?= "20060106"
+# Select the appropriate x11 library provider.  The diet-x11 libraries are
+# much smaller, but may not be as current as the standard x11 libraries; by
+# default we will select the standard libraries and permit the use of an
+# override if the user wishes (and has the correct PREFERRED_VERSIONs set).
+PREFERRED_PROVIDER_virtual/libx11              ?= "libx11"
 
 # Ensure consistency across all SlugOS builds for the provider of a relational
 # database - use the latest version of the SleepyCat Berkeley database
diff --git a/recipes/gnuradio/gnuradio_3.2.1.bb b/recipes/gnuradio/gnuradio_3.2.1.bb
new file mode 100644 (file)
index 0000000..649df09
--- /dev/null
@@ -0,0 +1,22 @@
+require gnuradio.inc
+
+DEPENDS += " gsl "
+
+PR = "${INC_PR}.1"
+
+S = "${WORKDIR}/gnuradio-3.2.1"
+
+EXTRA_OECONF += "--with-boost=${STAGING_DIR_TARGET}/usr CXXFLAGS=-DBOOST_SP_USE_PTHREADS --disable--usrp2"
+
+SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.1.tar.gz \
+    file://no-usrp2.patch;patch=1 \
+    file://gnuradio-neon.patch;patch=1;pnum=0 \
+     ${SOURCEFORGE_MIRROR}/libusb/libusb-0.1.12.tar.gz \
+"
+
+do_compile_append() {
+        sed -i -e s:${STAGING_DIR_TARGET}::g \
+               -e s:/${TARGET_SYS}::g \
+                  gnuradio-core/gnuradio-core.pc
+}
+