ncurses: add xterm terminfo file back
authorGrazvydas Ignotas <notasas@gmail.com>
Wed, 6 Jul 2016 21:42:03 +0000 (00:42 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Wed, 6 Jul 2016 21:42:03 +0000 (00:42 +0300)
how did I mess that up?

recipes/ncurses/ncurses_5.9.bb

index 5db856c..5a3ba80 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Ncurses library"
 HOMEPAGE = "http://www.gnu.org/software/ncurses/ncurses.html"
 LICENSE = "MIT"
 SECTION = "libs"
-PR = "r1"
+PR = "r2"
 
 DEPENDS = "ncurses-native unifdef-native"
 DEPENDS_virtclass-native = "unifdef-native"
@@ -130,7 +130,7 @@ do_install() {
 
         # include some basic terminfo files
         # stolen ;) from gentoo and modified a bit
-        for x in ansi console dumb linux rxvt screen screen-256color sun vt52 vt100 vt102 vt200 vt220 xterm-color xterm-xfree86 xterm-256color
+        for x in ansi console dumb linux rxvt screen screen-256color sun vt52 vt100 vt102 vt200 vt220 xterm-color xterm-xfree86 xterm-256color xterm
         do
                 local termfile="$(find "${D}${datadir}/terminfo/" -name "${x}" 2>/dev/null)"
                 local basedir="$(basename $(dirname "${termfile}"))"