xf86-video-omapfb: pandora: call op_power directly
authorGrazvydas Ignotas <notasas@gmail.com>
Mon, 6 Aug 2012 21:21:47 +0000 (00:21 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Mon, 6 Aug 2012 21:25:45 +0000 (00:25 +0300)
the latest addition to our huge assortment of hacks is this - run
op_power.sh instead of op_lid.sh, because the later can do things
like suspend or run zenity, causing deadlocks against X at least.

recipes/xorg-driver/xf86-video-omapfb/pandora_backlight_dim.patch
recipes/xorg-driver/xf86-video-omapfb_git.bb

index 4a0b843..db51b21 100644 (file)
@@ -31,7 +31,7 @@ index 7a57221..62f5ccb 100644
 +                      break;
 +      }
 +
-+      snprintf(cmd, sizeof(cmd), "/usr/pandora/scripts/op_lid.sh %d", arg);
++      snprintf(cmd, sizeof(cmd), "/usr/pandora/scripts/op_power.sh %d screensaver &", arg);
 +      system(cmd);
 +      blanking = arg;
 +
index 0030602..c78479e 100644 (file)
@@ -2,7 +2,7 @@ require xorg-driver-video.inc
 
 DESCRIPTION = "X.Org X server -- OMAP display driver"
 
-PR_append = "g"
+PR_append = "h"
 
 SRCREV = "db636c8436265c3d86c5b8e00785e45d55825c80"
 PV = "0.1.1+${PR}+gitr${SRCREV}"