python 2.5.2 RDEPENDS_python-logging += python-pickle
authorMichael Lauer <mickey@vanille-media.de>
Sat, 2 Aug 2008 11:26:17 +0000 (11:26 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Sat, 2 Aug 2008 11:26:17 +0000 (11:26 +0000)
contrib/python/generate-manifest-2.5.py
packages/python/python-2.5-manifest.inc
packages/python/python_2.5.2.bb

index 08a8a47..da5f7cc 100755 (executable)
@@ -240,7 +240,7 @@ if __name__ == "__main__":
     "atexit.* bisect.* code.* codeop.* dis.* heapq.* inspect.* keyword.* opcode.* repr.* token.* tokenize.* " + 
     "traceback.* linecache.* weakref.*" )
 
-    m.addPackage( 0, "python-logging", "Python Logging Support", "python-core python-io python-lang python-stringold",
+    m.addPackage( 1, "python-logging", "Python Logging Support", "python-core python-io python-lang python-pickle python-stringold",
     "logging" ) # package
 
     m.addPackage( 0, "python-lib-old-and-deprecated", "Python Deprecated Libraries", "python-core",
index 95a7bd8..a0ec692 100644 (file)
@@ -1,16 +1,11 @@
-########################################################################################################################
-### AUTO-GENERATED by '../../contrib/python/generate-manifest-2.5.py' [(C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>] on Mon Jul 21 17:03:43 2008
-###
-### Visit THE Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
-###
-### Warning: Manual edits will be lost!
-###
-########################################################################################################################
+# WARNING: This file is AUTO GENERATED: Manual edits will be lost next time I regenerate the file.
+# Generator: './generate-manifest-2.5.py' Version 20080722 (C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+# Visit the Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
  
 
-PROVIDES+="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-doctest python-tests python-core-dbg python-resource python-devel python-difflib python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
+PROVIDES+="python-profile python-threading python-distutils python-doctest python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-difflib python-math python-syslog python-hotshot python-unixadmin python-textutils python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
 
-PACKAGES="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-doctest python-tests python-core-dbg python-resource python-devel python-difflib python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
+PACKAGES="python-profile python-threading python-distutils python-doctest python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-difflib python-math python-syslog python-hotshot python-unixadmin python-textutils python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
 
 DESCRIPTION_python-profile="Python Basic Profiling Support"
 PR_python-profile="ml0"
@@ -27,10 +22,10 @@ PR_python-distutils="ml0"
 RDEPENDS_python-distutils="python-core"
 FILES_python-distutils="${libdir}/python2.5/config ${libdir}/python2.5/distutils "
 
-DESCRIPTION_python-textutils="Python Option Parsing, Text Wrapping and Comma-Separated-Value Support"
-PR_python-textutils="ml0"
-RDEPENDS_python-textutils="python-core python-io python-re python-stringold"
-FILES_python-textutils="${libdir}/python2.5/lib-dynload/_csv.so ${libdir}/python2.5/csv.* ${libdir}/python2.5/optparse.* ${libdir}/python2.5/textwrap.* "
+DESCRIPTION_python-doctest="Python framework for running examples in docstrings."
+PR_python-doctest="ml0"
+RDEPENDS_python-doctest="python-core python-lang python-io python-re python-unittest python-debugger python-difflib"
+FILES_python-doctest="${libdir}/python2.5/doctest.* "
 
 DESCRIPTION_python-codecs="Python Codecs, Encodings & i18n Support"
 PR_python-codecs="ml0"
@@ -97,11 +92,6 @@ PR_python-image="ml0"
 RDEPENDS_python-image="python-core"
 FILES_python-image="${libdir}/python2.5/colorsys.* ${libdir}/python2.5/imghdr.* ${libdir}/python2.5/lib-dynload/imageop.so ${libdir}/python2.5/lib-dynload/rgbimg.so "
 
-DESCRIPTION_python-doctest="Python framework for running examples in docstrings."
-PR_python-doctest="ml0"
-RDEPENDS_python-doctest="python-core python-lang python-io python-re python-unittest python-debugger python-difflib"
-FILES_python-doctest="${libdir}/python2.5/doctest.* "
-
 DESCRIPTION_python-tests="Python Tests"
 PR_python-tests="ml0"
 RDEPENDS_python-tests="python-core"
@@ -132,6 +122,11 @@ PR_python-math="ml0"
 RDEPENDS_python-math="python-core"
 FILES_python-math="${libdir}/python2.5/lib-dynload/cmath.so ${libdir}/python2.5/lib-dynload/math.so ${libdir}/python2.5/lib-dynload/_random.so ${libdir}/python2.5/random.* ${libdir}/python2.5/sets.* "
 
+DESCRIPTION_python-syslog="Python's Syslog Interface"
+PR_python-syslog="ml0"
+RDEPENDS_python-syslog="python-core"
+FILES_python-syslog="${libdir}/python2.5/lib-dynload/syslog.so "
+
 DESCRIPTION_python-hotshot="Python Hotshot Profiler"
 PR_python-hotshot="ml0"
 RDEPENDS_python-hotshot="python-core"
@@ -142,10 +137,10 @@ PR_python-unixadmin="ml0"
 RDEPENDS_python-unixadmin="python-core"
 FILES_python-unixadmin="${libdir}/python2.5/lib-dynload/nis.so ${libdir}/python2.5/lib-dynload/grp.so ${libdir}/python2.5/lib-dynload/pwd.so ${libdir}/python2.5/getpass.* "
 
-DESCRIPTION_python-syslog="Python's Syslog Interface"
-PR_python-syslog="ml0"
-RDEPENDS_python-syslog="python-core"
-FILES_python-syslog="${libdir}/python2.5/lib-dynload/syslog.so "
+DESCRIPTION_python-textutils="Python Option Parsing, Text Wrapping and Comma-Separated-Value Support"
+PR_python-textutils="ml0"
+RDEPENDS_python-textutils="python-core python-io python-re python-stringold"
+FILES_python-textutils="${libdir}/python2.5/lib-dynload/_csv.so ${libdir}/python2.5/csv.* ${libdir}/python2.5/optparse.* ${libdir}/python2.5/textwrap.* "
 
 DESCRIPTION_python-tkinter="Python Tcl/Tk Bindings"
 PR_python-tkinter="ml0"
@@ -208,8 +203,8 @@ RDEPENDS_python-pydoc="python-core python-lang python-stringold python-re"
 FILES_python-pydoc="${bindir}/pydoc ${libdir}/python2.5/pydoc.* "
 
 DESCRIPTION_python-logging="Python Logging Support"
-PR_python-logging="ml0"
-RDEPENDS_python-logging="python-core python-io python-lang python-stringold"
+PR_python-logging="ml1"
+RDEPENDS_python-logging="python-core python-io python-lang python-pickle python-stringold"
 FILES_python-logging="${libdir}/python2.5/logging "
 
 DESCRIPTION_python-mailbox="Python Mailbox Format Support"
index b47ed0b..707c0f5 100644 (file)
@@ -6,7 +6,7 @@ PRIORITY = "optional"
 DEPENDS = "python-native readline zlib gdbm openssl sqlite3 tcl tk"
 DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
 # bump this on every change in contrib/python/generate-manifest-2.5.py
-PR = "ml7"
+PR = "ml8"
 
 PYTHON_MAJMIN = "2.5"