oe_audit.py: Properly handle used version..
authorHolger Hans Peter Freyther <zecke@selfish.org>
Thu, 18 Mar 2010 13:18:07 +0000 (14:18 +0100)
committerHolger Hans Peter Freyther <zecke@selfish.org>
Mon, 22 Mar 2010 03:04:41 +0000 (04:04 +0100)
There might be a third column for -s and we want to
use that one. It seems bitbake is a bit confused about
latest vs. current... and it is helping.

contrib/qa/oe_audit.py

index 905f110..bb7915b 100755 (executable)
@@ -11,16 +11,22 @@ def read_available(filename):
     packages = {}
 
     for line in f:
-        if line.startswith("NOTE: ") or line.startswith("Parsing .bb"):
+        if line.startswith("NOTE: ") or line.startswith("Parsing .bb") or line.startswith("done."):
             continue
 
         # str.split can not be used as we have multiple whitespace
-        first_space = line.find(" ")
-        package = line[0:first_space]
-        rest = line[first_space+1:]
-        pv = rest.strip().split(" ")[0]
-
-        packages[package] = pv
+        split = line.split(" ", 1)
+        package = split[0]
+        rest = split[1].strip()
+
+        # we might have a latest package...
+        split = rest.split(" ", 1)
+        if len(split) == 2:
+            version = split[1].strip()
+        else:
+            version = split[0]
+
+        packages[package] = version
     return packages