marvel-gspi-fw: added firmware for WiFi bugmodule
authorMarcin Juszkiewicz <marcin@buglabs.net>
Thu, 23 Apr 2009 12:01:35 +0000 (14:01 +0200)
committerMarcin Juszkiewicz <marcin@buglabs.net>
Thu, 23 Apr 2009 18:11:59 +0000 (20:11 +0200)
This is firmware for not-yet-released-into-sales wifi/bt bugmodule.

recipes/firmwares/marvell-gspi-fw/9.70.3-p37.tar.gz [new file with mode: 0644]
recipes/firmwares/marvell-gspi-fw/Marvell-Licence.txt [new file with mode: 0644]
recipes/firmwares/marvell-gspi-fw_9.70.3-p37.bb [new file with mode: 0644]

diff --git a/recipes/firmwares/marvell-gspi-fw/9.70.3-p37.tar.gz b/recipes/firmwares/marvell-gspi-fw/9.70.3-p37.tar.gz
new file mode 100644 (file)
index 0000000..c7bf768
Binary files /dev/null and b/recipes/firmwares/marvell-gspi-fw/9.70.3-p37.tar.gz differ
diff --git a/recipes/firmwares/marvell-gspi-fw/Marvell-Licence.txt b/recipes/firmwares/marvell-gspi-fw/Marvell-Licence.txt
new file mode 100644 (file)
index 0000000..87035b0
--- /dev/null
@@ -0,0 +1,40 @@
+FIRMWARE LICENSE TERMS*
+
+Copyright (c) Marvell International Ltd.
+
+All rights reserved.
+
+Redistribution. Redistribution and use in binary form, without modification,
+are permitted provided that the following conditions are met:
+
+* Redistributions must reproduce the above copyright notice and the following
+  disclaimer in the documentation and/or other materials provided with the
+  distribution.
+
+* Neither the name of Marvell International Ltd. nor the names of its suppliers
+  may be used to endorse or promote products derived from this software without
+  specific prior written permission.
+
+* No reverse engineering, decompilation, or disassembly of this software is
+  permitted.
+
+Limited patent license. Marvell International Ltd. grants a world-wide,
+royalty-free, non-exclusive license under patents it now or hereafter owns or
+controls to make, have made, use, import, offer to sell and sell ("Utilize")
+this software, but solely to the extent that any such patent is necessary to
+Utilize the software alone, or in combination with an operating system licensed
+under an approved Open Source license as listed by the Open Source Initiative
+at http://opensource.org/licenses. The patent license shall not apply to any
+other combinations which include this software. No hardware per se is licensed
+hereunder.
+
+DISCLAIMER. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
+THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.*
diff --git a/recipes/firmwares/marvell-gspi-fw_9.70.3-p37.bb b/recipes/firmwares/marvell-gspi-fw_9.70.3-p37.bb
new file mode 100644 (file)
index 0000000..017ec70
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Firmware for Marvel 8686 gspi wifi chipset"
+LICENCE = "closed"
+
+SRC_URI = "file://${PV}.tar.gz \
+           file://Marvell-Licence.txt"
+
+S = "${WORKDIR}/${PV}/FwImage"
+
+do_install() {
+
+       install -d ${D}${base_libdir}/firmware
+       install -m 0644 gspi8686.bin helper_gspi.bin ${D}${base_libdir}/firmware
+       install -m 0644 ${WORKDIR}/Marvell-Licence.txt ${D}${base_libdir}/firmware
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${base_libdir}/firmware"
+
+PACKAGE_ARCH = "all"