libgles-omap3, omap3-sgx-modules: add 3.01.00.05 release
authorKoen Kooi <k-kooi@ti.com>
Wed, 17 Mar 2010 15:18:32 +0000 (16:18 +0100)
committerGrazvydas Ignotas <notasas@gmail.com>
Sat, 22 Jan 2011 22:14:30 +0000 (00:14 +0200)
* DEFAULT_PREFERENCE = "-1" till it becomes widely available
* Hardcodes 3430, discussing with upstream to make it universal

recipes/powervr-drivers/libgles-omap3.inc
recipes/powervr-drivers/libgles-omap3_3.01.00.05.bb [new file with mode: 0644]

index 2562ed6..55a0206 100644 (file)
@@ -33,6 +33,9 @@ TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
 require ../ti/ti-eula-unpack.inc
 
 BINLOCATION ?= "${S}/gfx_rel"
+ES2LOCATION ?= "${S}/gfx_rel_es2.x"
+ES3LOCATION ?= "${S}/gfx_rel_es3.x"
+ES5LOCATION ?= "${S}/gfx_rel_es5.x"
 
 do_configure() {
        # Attempt to fix up the worst offenders for file permissions
@@ -155,19 +158,28 @@ do_install () {
        echo "[default]" > ${D}${sysconfdir}/powervr.ini
        echo "WindowSystem=libpvrPVR2D_FRONTWSEGL.so" >> ${D}${sysconfdir}/powervr.ini
 
-       # The ES2.x and ES3.x CPUs have different SGX hardware, so we need to install 2 sets of userspace
+       # The ES2.x, ES3.x and ES5.x CPUs have different SGX hardware, so we need to install 2 sets of userspace
 
+       install -d ${D}${libdir}/ES5.0
        install -d ${D}${libdir}/ES3.0
        install -d ${D}${libdir}/ES2.0
+
+       install -d ${D}${bindir}/ES5.0
        install -d ${D}${bindir}/ES3.0
        install -d ${D}${bindir}/ES2.0
 
-       cp -pPR ${S}/gfx_rel_es2.x/lib* ${D}${libdir}/ES2.0/
-       cp ${S}/gfx_rel_es2.x//p[dv]* ${D}${bindir}/ES2.0/
+
+       cp -pPR ${ES2LOCATION}/lib*${IMGPV} ${D}${libdir}/ES2.0/
+       cp ${ES2LOCATION}/p[dv]* ${D}${bindir}/ES2.0/
 
        cp -pPR ${D}${libdir}/lib*${IMGPV} ${D}${libdir}/ES3.0/
        cp ${D}${bindir}/p[dv]* ${D}${bindir}/ES3.0
 
+       if [ -e ${ES5LOCATION} ] ; then 
+               cp -pPR ${ES5LOCATION}/lib*${IMGPV} ${D}${libdir}/ES5.0/
+               cp ${ES3LOCATION}/p[dv]* ${D}${bindir}/ES5.0/
+       fi
+
        install -d ${D}${prefix}/share/applications
        cp ${WORKDIR}/*.desktop ${D}${prefix}/share/applications
        rm ${D}${prefix}/share/applications/sample.desktop
diff --git a/recipes/powervr-drivers/libgles-omap3_3.01.00.05.bb b/recipes/powervr-drivers/libgles-omap3_3.01.00.05.bb
new file mode 100644 (file)
index 0000000..4d98186
--- /dev/null
@@ -0,0 +1,23 @@
+DEFAULT_PREFERENCE = "-1"
+
+BINLOCATION = "${S}/gfx_rel_es3.x"
+
+ES2LOCATION = "${S}/gfx_rel_es2.x"
+ES3LOCATION = "${S}/gfx_rel_es3.x"
+ES5LOCATION = "${S}/gfx_rel_es5.x"
+
+
+require libgles-omap3.inc
+
+# download required binary distribution from:
+# http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_01_00_02.bin
+
+SGXPV = "3_01_00_05"
+IMGPV = "1.4.14.2616"
+BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
+
+
+
+
+
+