udev 151: mount.sh: allow to filter by uuid
authorGrazvydas Ignotas <notasas@gmail.com>
Sun, 10 Jan 2016 17:37:25 +0000 (19:37 +0200)
committerGrazvydas Ignotas <notasas@gmail.com>
Sun, 10 Jan 2016 17:37:25 +0000 (19:37 +0200)
Galaxis requested this, see:
https://pyra-handheld.com/boards/threads/superzaxxon-v1-73-maintenance-release.76703/page-2#post-1361811

recipes/udev/udev-151/omap3-pandora/mount.sh
recipes/udev/udev_151.bb

index 73ab5e7..0ba6b10 100755 (executable)
@@ -12,11 +12,12 @@ blkid="/sbin/blkid"
 name="`basename "$DEVNAME"`"
 name2="`$blkid "$DEVNAME" -c /dev/null -o value -s LABEL | sed 's/ /_/g'`"
 name3=$(echo $DEVNAME | sed 's/.*dev.//g')
+uuid="`$blkid "$DEVNAME" -c /dev/null -o value -s UUID`"
 uid=$(cat /tmp/currentuid)
 
 for line in `grep -v ^# /etc/udev/mount.blacklist`
 do
-       if ( echo "$DEVNAME" | grep -q "$line" )
+       if echo "$DEVNAME" | grep -q "$line" || echo "$uuid" | grep -q "$line"
        then
                logger "udev/mount.sh" "[$DEVNAME] is blacklisted, ignoring"
                exit 0
index b940fd5..fac47f8 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
 the hotplug package and requires a kernel not older than 2.6.12."
 LICENSE = "GPLv2+"
 
-PR = "r25"
+PR = "r26"
 
 # Untested
 DEFAULT_PREFERENCE = "-1"