ecore: add patch that fixes the ecore-fb touchscreen initialization
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Sun, 14 Mar 2010 19:52:30 +0000 (20:52 +0100)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Sun, 14 Mar 2010 20:00:11 +0000 (21:00 +0100)
With this patch, we have a working touchscreen in framebuffer mode again

recipes/efl1/ecore.inc
recipes/efl1/ecore/fix-ecore-fb-initialization.patch [new file with mode: 0644]
recipes/efl1/ecore_svn.bb

index ef3ba55..69d3f76 100644 (file)
@@ -5,10 +5,12 @@ DEPENDS = "gettext-native virtual/libiconv curl eet evas tslib glib-2.0 \
 # optional
 # DEPENDS += "directfb libsdl-x11 openssl virtual/libiconv"
 PV = "0.9.9.060+svnr${SRCPV}"
-PR = "r3"
+PR = "r4"
 
 inherit efl
 
+SRC_URI += "file://fix-ecore-fb-initialization.patch;patch=1"
+
 do_configure_prepend() {
        touch ${S}/po/Makefile.in.in || true
        sed -i -e 's: po::g' ${S}/Makefile.am
@@ -71,5 +73,3 @@ FILES_${PN}-txt = "${libdir}/libecore_txt*.so.*"
 FILES_${PN}-x = "${libdir}/libecore_x*.so.*"
 FILES_${PN}-input = "${libdir}/libecore_input*.so.*"
 
-
-
diff --git a/recipes/efl1/ecore/fix-ecore-fb-initialization.patch b/recipes/efl1/ecore/fix-ecore-fb-initialization.patch
new file mode 100644 (file)
index 0000000..2ac61ca
--- /dev/null
@@ -0,0 +1,29 @@
+#
+# The whole ecore-fb init logic is somewhat flawed; with this patch we
+# get at least a working touchscreen w/ tslib again.
+#
+# Signed-off-by: Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+#
+
+Index: ecore/src/lib/ecore_fb/ecore_fb.c
+===================================================================
+--- ecore.orig/src/lib/ecore_fb/ecore_fb.c
++++ ecore/src/lib/ecore_fb/ecore_fb.c
+@@ -46,6 +46,9 @@
+    if (!ecore_fb_vt_init())
+      return --_ecore_fb_init_count;
++     
++   if (!ecore_fb_ts_init())
++     return --_ecore_fb_init_count;
+    ECORE_FB_EVENT_KEY_DOWN          = ecore_event_type_new();
+    ECORE_FB_EVENT_KEY_UP            = ecore_event_type_new();
+@@ -70,6 +73,7 @@
+    if (--_ecore_fb_init_count != 0)
+      return _ecore_fb_init_count;
++   ecore_fb_ts_shutdown();
+    ecore_fb_vt_shutdown();
+    return _ecore_fb_init_count;
index 2354673..6fc4676 100644 (file)
@@ -1,10 +1,11 @@
 require ecore.inc
-PR = "r7"
+PR = "r8"
 
-SRC_URI += "file://iconv.patch;patch=1;maxrev=43996 \
-            file://exit_uclibc_dns.patch;patch=1;maxrev=47076 \
-            file://exit_uclibc.patch;patch=1 \
-           "
+SRC_URI += "\
+  file://iconv.patch;patch=1;maxrev=43996 \
+  file://exit_uclibc_dns.patch;patch=1;maxrev=47076 \
+  file://exit_uclibc.patch;patch=1 \
+"
 
 EXTRA_OECONF = "\
   --x-includes=${STAGING_INCDIR}/X11 \