efl, e-wm: Add a sed fix for X11 system headers
authorJustin Patrin <papercrane@gmail.com>
Mon, 10 Oct 2005 18:05:42 +0000 (18:05 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Mon, 10 Oct 2005 18:05:42 +0000 (18:05 +0000)
classes/efl.bbclass
packages/e17/e-wm_0.16.999.015.bb

index 964748e..b438ca6 100644 (file)
@@ -40,6 +40,7 @@ export IMLIB2_CONFIG          = "${STAGING_BINDIR}/imlib2-config${@binconfig_suffix(d)}"
 
 do_compile_prepend() {
        find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+       find ${S} -name Makefile | xargs sed -i 's:/usr/X11R6/include:${STAGING_INCDIR}:'
 }
 
 do_stage_append () {
index 7a7291a..c39b2ab 100644 (file)
@@ -36,6 +36,7 @@ FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir}"
 
 do_compile_prepend() {
         find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+       find ${S} -name Makefile | xargs sed -i 's:/usr/X11R6/include:${STAGING_INCDIR}:'
        mv "${WORKDIR}/themes/default_entry.edc" "${S}/data/themes/"
        mv "${WORKDIR}/themes/images/focus.png" "${S}/data/themes/images/"
        mv "${WORKDIR}/themes/images/entry.png" "${S}/data/themes/images/"