python: Fixed some recipes so the build server doesn't complain
authorMichael Mrozek <EvilDragon@openpandora.org>
Sat, 14 Dec 2013 13:34:20 +0000 (14:34 +0100)
committerMichael Mrozek <EvilDragon@openpandora.org>
Sat, 14 Dec 2013 13:34:20 +0000 (14:34 +0100)
recipes/python/python-ecore_svn.bb
recipes/python/python-edbus_svn.bb
recipes/python/python-edje/0001-fix-unicode-conversion.patch
recipes/python/python-edje_svn.bb
recipes/python/python-elementary_svn.bb
recipes/python/python-emotion_svn.bb
recipes/python/python-evas_svn.bb
recipes/python/python-pyrtc_git.bb

index 7d7fbba..94daaf1 100644 (file)
@@ -1,4 +1,8 @@
 require python-efl.inc
 SRCREV = "${EFL_SRCREV}"
 DEPENDS += "python-evas ecore"
-RDEPENDS_${PN} += "python-evas"
+RDEPENDS += "python-evas"
+
+do_stage() {
+    distutils_stage_all
+}
index 801cc2d..00fffed 100644 (file)
@@ -1,5 +1,7 @@
 require python-efl.inc
 SRCREV = "${EFL_SRCREV}"
 DEPENDS += "edbus python-dbus"
-RDEPENDS_${PN} += "python-dbus"
-SRCNAME = "python-e_dbus"
+RDEPENDS += "python-dbus"
+
+SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/BINDINGS/python;module=python-e_dbus;proto=http"
+S = "${WORKDIR}/python-e_dbus"
index 3b0cdc6..7964e09 100644 (file)
@@ -11,7 +11,7 @@ diff --git a/edje/edje.c_edje_object.pxi b/edje/edje.c_edje_object.pxi
 index 0f4da68..21c237e 100644
 --- a/edje/edje.c_edje_object.pxi
 +++ b/edje/edje.c_edje_object.pxi
-@@ -415,17 +415,20 @@
+@@ -391,17 +391,20 @@ cdef public class Edje(evas.c_evas.Object) [object PyEdje, type PyEdje_Type]:
          else:
              raise TypeError("func must be callable or None")
  
@@ -26,7 +26,7 @@ index 0f4da68..21c237e 100644
      def part_text_get(self, char *part):
 -        "@rtype: str"
 +        "@rtype: unicode"
-         cdef const_char_ptr s
+         cdef char *s
          s = edje_object_part_text_get(self.obj, part)
          if s == NULL:
              return None
@@ -34,5 +34,8 @@ index 0f4da68..21c237e 100644
 -            return s
 +            return s.decode("utf8")
  
-     def part_text_select_all(self, char *part):
-         edje_object_part_text_select_all(self.obj, part)
+     def part_swallow(self, char *part, c_evas.Object obj):
+         """Swallows an object into the edje
+-- 
+1.5.6.3
+
index 09cfbb0..2c087ca 100644 (file)
@@ -1,6 +1,6 @@
 require python-efl.inc
 SRCREV = "${EFL_SRCREV}"
 DEPENDS += "edje python-evas"
-RDEPENDS_${PN} += "python-evas"
+RDEPENDS += "python-evas"
 
-SRC_URI += "file://0001-fix-unicode-conversion.patch"
+SRC_URI += "file://0001-fix-unicode-conversion.patch;patch=1"
index ea184d0..ad82e04 100644 (file)
@@ -1,4 +1,10 @@
 require python-efl.inc
 SRCREV = "${EFL_SRCREV}"
-DEPENDS += "elementary python-evas"
-RDEPENDS_${PN} += "python-evas python-ecore python-edje" 
+DEPENDS += "elementary"
+RDEPENDS += "python-evas python-ecore python-edje" 
+PV = "0.1+svnr${SRCPV}"
+PR = "ml0"
+
+do_stage() {         
+       distutils_stage_all 
+}  
index 9f558f8..38e1355 100644 (file)
@@ -1,4 +1,4 @@
 require python-efl.inc
 SRCREV = "${EFL_SRCREV}"
 DEPENDS += "emotion python-evas"
-RDEPENDS_${PN} += "python-ecore"
+RDEPENDS += "python-ecore"
index 1aaec71..d2568ba 100644 (file)
@@ -1,3 +1,8 @@
 require python-efl.inc
 SRCREV = "${EFL_SRCREV}"
 DEPENDS += "evas"
+
+do_stage() {
+       distutils_stage_all
+       distutils_stage_headers
+}
index bd8452f..9b51189 100644 (file)
@@ -1,16 +1,16 @@
-require ../freesmartphone/python-helpers.inc
-
 DESCRIPTION = "PyRTC is a python extension module that supports talking to the \
 RTC (Real Time Clock) found in most PCs and SOCs"
 SECTION = "devel/python"
+HOMEPAGE = "http://www.freesmartphone.org"
 AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
 LICENSE = "GPLv2"
 SRCNAME = "pyrtc"
 DEPENDS = "python-cython-native"
 SRCREV = "${FSO_PYTHONHELPERS_SRCREV}"
-PV = "1.0.0+gitr${SRCPV}"
+PV = "1.0.0+gitr${SRCREV}"
 PR = "ml1"
 
+SRC_URI = "git://git.freesmartphone.org/python-helpers.git;protocol=git;branch=master"
 S = "${WORKDIR}/git/${SRCNAME}"
 
 inherit distutils