curl: support openssl in CURL_FEATURES.
authorMichael Smith <msmith@cbnco.com>
Fri, 23 Oct 2009 15:14:34 +0000 (11:14 -0400)
committerMichael Smith <msmith@cbnco.com>
Sun, 25 Oct 2009 20:28:15 +0000 (16:28 -0400)
Default is still gnutls.

Also switch to INC_PR.

Signed-off-by: Michael Smith <msmith@cbnco.com>
recipes/curl/curl-common.inc
recipes/curl/curl-native_7.18.2.bb
recipes/curl/curl-native_7.19.6.bb
recipes/curl/curl-sdk_7.18.2.bb
recipes/curl/curl_7.18.2.bb
recipes/curl/curl_7.19.5.bb
recipes/curl/curl_7.19.6.bb

index ce4f5f2..29af47e 100644 (file)
@@ -6,8 +6,10 @@ SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
            file://pkgconfig_fix.patch;patch=1"
 S = "${WORKDIR}/curl-${PV}"
 
+INC_PR = "r2"
+
 CURL_FEATURES ?= "zlib,gnutls,cookies,crypto-auth,dict,file,ftp,http,telnet,tftp"
-# other allowed features: ipv6, ares
+# other allowed features: ipv6, ares, openssl
 
 inherit autotools pkgconfig binconfig
 
@@ -15,7 +17,6 @@ EXTRA_OECONF = " \
                 --without-libssh2 \
                --with-random=/dev/urandom \
                --without-libidn \
-                --without-ssl \
                "
 
 python __anonymous() {
@@ -37,6 +38,11 @@ python __anonymous() {
                 deps.append("gnutls")
         else:
                 oeconf += " --without-gnutls"
+        if 'openssl' in f:
+                oeconf += " --with-ssl=${STAGING_LIBDIR}/../"
+                deps.append("openssl")
+        else:
+                oeconf += " --without-ssl"
         if 'ares' in f:
                 oeconf += " --enable-ares"
                 deps.append("c-ares")
index c95591b..d395021 100644 (file)
@@ -1,7 +1,7 @@
 require curl-common.inc
 inherit native
 DEPENDS = "zlib-native"
-PR = "r1"
+PR = "${INC_PR}.1"
 
 do_stage () {
        autotools_stage_all
index 2f49ad1..d395021 100644 (file)
@@ -1,6 +1,7 @@
 require curl-common.inc
 inherit native
 DEPENDS = "zlib-native"
+PR = "${INC_PR}.1"
 
 do_stage () {
        autotools_stage_all
index 35b0d88..8eed3d6 100644 (file)
@@ -1,7 +1,7 @@
 require curl-common.inc
 inherit sdk
 DEPENDS = "zlib-sdk"
-PR = "r1"
+PR = "${INC_PR}.1"
 
 do_stage () {
         install -d ${STAGING_INCDIR}/curl
index 3de6da4..84c0d07 100644 (file)
@@ -1,4 +1,4 @@
 require curl-common.inc
 require curl-target.inc
 
-PR = "r1"
+PR = "${INC_PR}.1"
index b5b6182..d0577b0 100644 (file)
@@ -3,4 +3,4 @@ require curl-target.inc
 
 SRC_URI += "file://off_t_abi_fix.patch;patch=1;pnum=0 \
             file://curl-add_all_algorithms.patch;patch=1"
-PR = "r1"
+PR = "${INC_PR}.1"
index d5ca1bb..e8319b8 100644 (file)
@@ -2,3 +2,4 @@ require curl-common.inc
 require curl-target.inc
 
 SRC_URI += "file://off_t_abi_fix.patch;patch=1;pnum=0"
+PR = "${INC_PR}.1"