makedevs: fix interpretation of device table (count).
authorAndrea Adami <andrea.adami@gmail.com>
Wed, 21 Oct 2009 22:18:22 +0000 (00:18 +0200)
committerAndrea Adami <andrea.adami@gmail.com>
Wed, 21 Oct 2009 22:31:01 +0000 (00:31 +0200)
Signed-off-by: Antonio Ospite <ospite@studenti.unina.it>
recipes/makedevs/makedevs-1.0.0/makedevs.c
recipes/makedevs/makedevs_1.0.0.bb

index c7ad722..80f21f0 100644 (file)
@@ -221,7 +221,7 @@ static int interpret_table_entry(char *line)
                        dev_t rdev;
                        char buf[80];
 
-                       for (i = start; i < count; i++) {
+                       for (i = start; i < start+count; i++) {
                                sprintf(buf, "%s%d", name, i);
                                /* FIXME:  MKDEV uses illicit insider knowledge of kernel 
                                 * major/minor representation...  */
index 5579e61..cab1a4c 100644 (file)
@@ -6,7 +6,7 @@ PRIORITY = "required"
 SRC_URI = "file://makedevs.c"
 S = "${WORKDIR}/makedevs-${PV}"
 
-PR = "r7"
+PR = "r8"
 
 inherit update-alternatives