propagate from branch 'org.openembedded.dev' (head 558d7f8556530ca23dc6e4b7d687d6727d...
authorKoen Kooi <koen@openembedded.org>
Wed, 23 Jan 2008 10:55:05 +0000 (10:55 +0000)
committerKoen Kooi <koen@openembedded.org>
Wed, 23 Jan 2008 10:55:05 +0000 (10:55 +0000)
            to branch 'org.openembedded.dev.avr32' (head d7597829fe950aa86acdfe521d11843d7277261c)

1  2 
packages/linux/linux.inc
packages/linux/linux_2.6.23.bb

@@@ -99,6 -99,23 +99,11 @@@ do_configure_prepend() 
          yes '' | oe_runmake oldconfig
  }
  
 -# Support checking the kernel size since some kernels need to reside in partitions
 -# with a fixed length or there is a limit in transferring the kernel to memory
 -do_sizecheck() {
 -        if [ ! -z "${KERNEL_IMAGE_MAXSIZE}" ]; then
 -            size=`ls -l arch/${ARCH}/boot/${KERNEL_IMAGETYPE} | awk '{ print $5}'`
 -            if [ $size -ge ${KERNEL_IMAGE_MAXSIZE} ]; then
 -                    rm arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
 -                    die  "This kernel (size=$size) is too big for your device. Please reduce the size of the kernel by making more of it modular."
 -            fi
 -        fi
 -}
 -
+ do_configure_append_avr32() {
+         sed -i -e s:-mno-pic::g arch/avr32/Makefile
+ }
  UBOOT_ENTRYPOINT ?= "20008000"
  
  do_compile_append() {
@@@ -18,13 -18,15 +19,19 @@@ SRC_URI = "${KERNELORG_MIRROR}/pub/linu
           "
  
  # Bug fixes on the 2.6.23.x stable branch
 -SRC_URI += "http://www.kernel.org/pub/linux/kernel/v2.6/patch-2.6.23.12.bz2;patch=1"
 +SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-2.6.23.12.bz2;patch=1"
 +# Real-time preemption (includes CFS). This is experimental and requires a different defconfig.
 +#SRC_URI += "file://patch-2.6.23.12-rt14;patch=1"
 +# Only the Completely Fair Scheduler (CFS), the official backport from 2.6.24
 +SRC_URI += "http://people.redhat.com/mingo/cfs-scheduler/sched-cfs-v2.6.23.12-v24.1.patch;patch=1"
  # Add support for squashfs-lzma (a highly compressed read-only filesystem)
  SRC_URI += "http://kamikaze.waninkoko.info/patches/2.6.23/klight1/broken-out/squashfs-lzma-2.6.23.patch;patch=1"
+ # Completely fair scheduler
+ SRC_URI += "http://people.redhat.com/mingo/cfs-scheduler/sched-cfs-v2.6.23.12-v24.1.patch;patch=1"
+ SRC_URI_append_avr32 = " \
+                        http://avr32linux.org/twiki/pub/Main/LinuxPatches/linux-2.6.23.atmel.3.patch.bz2;patch=1 \
+                        "
  
  SRC_URI_append_cm-x270 = "\
        file://0001-cm-x270-base2.patch;patch=1 \