initscripts: Have sysfs.sh do similar checks to rcS and bump PR.
authorTom Rini <tom_rini@mentor.com>
Thu, 18 Feb 2010 17:41:08 +0000 (10:41 -0700)
committerTom Rini <tom_rini@mentor.com>
Thu, 18 Feb 2010 17:41:08 +0000 (10:41 -0700)
rcS checks for [ -e /sys/kernel ], sysfs.sh, for proc will check
-e /proc && ! -e /proc/mounts, so for sysfs check for
-e /sys && ! -e /sys/kernel && sysfs in /proc/filesystems

recipes/initscripts/initscripts-1.0/sysfs.sh
recipes/initscripts/initscripts_1.0.bb

index 4486128..b242614 100644 (file)
@@ -4,7 +4,7 @@ if [ -e /proc ] && ! [ -e /proc/mounts ]; then
   mount -t proc proc /proc
 fi
 
-if [ -e /sys ] && grep -q sysfs /proc/filesystems; then
+if [ -e /sys ] && ! [ -e /sys/kernel ] && grep -q sysfs /proc/filesystems; then
   mount sysfs /sys -t sysfs
 fi
 
index 6642144..1bd6706 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "required"
 DEPENDS = "makedevs"
 RDEPENDS = "makedevs"
 LICENSE = "GPL"
-PR = "r115"
+PR = "r116"
 
 SRC_URI = "file://functions \
            file://halt \