uclibc-nptl: Update to lastest git rev.
authorKhem Raj <raj.khem@gmail.com>
Mon, 7 Dec 2009 17:52:13 +0000 (09:52 -0800)
committerKhem Raj <raj.khem@gmail.com>
Mon, 7 Dec 2009 17:52:13 +0000 (09:52 -0800)
* Add patch to fix build issue in rpc.
* Apply installfix patch to sort out parallel builds.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/uclibc/uclibc-nptl/installfix.patch [new file with mode: 0644]
recipes/uclibc/uclibc-nptl/uclibc_rpc_thread.patch [new file with mode: 0644]
recipes/uclibc/uclibc_nptl.bb

diff --git a/recipes/uclibc/uclibc-nptl/installfix.patch b/recipes/uclibc/uclibc-nptl/installfix.patch
new file mode 100644 (file)
index 0000000..61908df
--- /dev/null
@@ -0,0 +1,13 @@
+Index: git/Makefile.in
+===================================================================
+--- git.orig/Makefile.in       2009-12-04 12:53:00.000000000 -0800
++++ git/Makefile.in    2009-12-04 16:25:28.000000000 -0800
+@@ -300,7 +300,7 @@ else
+ endif
+ # Installs development library links.
+-install_dev: install_headers all
++install_dev: install_headers install_runtime
+       $(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)lib
+       -$(INSTALL) -m 644 lib/*.[ao] $(PREFIX)$(DEVEL_PREFIX)lib/
+ ifeq ($(HAVE_SHARED),y)
diff --git a/recipes/uclibc/uclibc-nptl/uclibc_rpc_thread.patch b/recipes/uclibc/uclibc-nptl/uclibc_rpc_thread.patch
new file mode 100644 (file)
index 0000000..8c2b85d
--- /dev/null
@@ -0,0 +1,12 @@
+Index: git/libc/inet/rpc/rpc_thread.c
+===================================================================
+--- git.orig/libc/inet/rpc/rpc_thread.c        2009-12-04 13:13:09.000000000 -0800
++++ git/libc/inet/rpc/rpc_thread.c     2009-12-04 13:13:17.000000000 -0800
+@@ -14,6 +14,7 @@
+ #ifdef __UCLIBC_HAS_THREADS__
+ #include <bits/libc-tsd.h>
++#include <bits/libc-lock.h>
+ /* Variable used in non-threaded applications or for the first thread.  */
+ static struct rpc_thread_variables __libc_tsd_RPC_VARS_mem;
index d5d6d1a..a910590 100644 (file)
@@ -7,7 +7,7 @@
 # on whether the base patches apply to the selected (SRCDATE) svn release.
 #
 UCLIBC_BASE ?= "0.9.30"
-SRCREV="8a6a88f5032ccbc3bfb8836c783a55316b156481"
+SRCREV="b3d31460fbf188997c7337296a61409529f7c974"
 PV = "${UCLIBC_BASE}+gitr${SRCREV}"
 DEFAULT_PREFERENCE = "-1"
 #DEFAULT_PREFERENCE is 0 (empty), releases have a preference of 1 so take
@@ -34,6 +34,8 @@ SRC_URI = "git://uclibc.org/uClibc.git;protocol=git;branch=nptl \
        file://uclibc-arm-ftruncate64.patch;patch=1 \
        file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch;patch=1 \
        file://uclibc_arm_remove_duplicate_sysdep_defs.patch;patch=1 \
+       file://uclibc_rpc_thread.patch;patch=1 \
+       file://installfix.patch;patch=1 \
        "
 
 S = "${WORKDIR}/git"