usermanual: Some more spelling fixes
authorHolger Hans Peter Freyther <zecke@selfish.org>
Tue, 11 Aug 2009 13:00:31 +0000 (15:00 +0200)
committerHolger Hans Peter Freyther <zecke@selfish.org>
Tue, 11 Aug 2009 13:00:31 +0000 (15:00 +0200)
docs/usermanual/chapters/getting_oe.xml
docs/usermanual/chapters/metadata.xml
docs/usermanual/chapters/recipes.xml
docs/usermanual/chapters/usage.xml

index 1d51a55..bd376c3 100644 (file)
@@ -209,7 +209,7 @@ $ <command>vi</command> build/conf/local.conf</screen>
         the following three
         entries: <varname>BBFILES</varname>, <varname>DISTRO</varname>
         and <varname>MACHINE</varname>. For example, consider the following
-        mininal <literal>local.conf</literal> file for the &Aring;ngstr&ouml;m
+        minimal <literal>local.conf</literal> file for the &Aring;ngstr&ouml;m
         distribution and the Openmoko gta01 machine:
 
         <screen>
@@ -294,7 +294,7 @@ MACHINE = "om-gta01"</screen>
 
         <varlistentry>
           <term><filename>meta/</filename></term>
-          <listitem><para>A collection of usefull meta tasks and recipes that
+          <listitem><para>A collection of useful meta tasks and recipes that
               don't fit in a general category.</para></listitem>
         </varlistentry>
 
index 3e76b2d..c698be9 100644 (file)
@@ -67,7 +67,7 @@
         <varlistentry>
           <term><filename>recipes/</filename></term>
           <listitem>
-            <para>Conatins all of the
+            <para>Contains all of the
               <application>BitBake</application> <filename>.bb</filename>
               files. There is a subdirectory for each task or application
               and within that subdirectory is
index e609e98..74e8e16 100644 (file)
@@ -146,7 +146,7 @@ VAR2 = "The version is ${PV}"</screen></para>
         <term>Conditional assignment</term>
 
         <listitem>
-          <para>Conditional assignement is used to assign a value to a
+          <para>Conditional assignment is used to assign a value to a
           variable, but only when the variable is currently unset. This is
           commonly used to provide a default value for use when no specific
           definition is provided by the machine or distro configuration of the
@@ -1503,7 +1503,7 @@ inherit autotools</screen></para>
           example from net-snmp shows oe_runconf being called manually so that
           the parameter for specifying the endianess can be computed and
           passed in to the configure script:<screen>do_configure() {
-    # Additional flag based on target endiness (see siteinfo.bbclass)
+    # Additional flag based on target endianess (see siteinfo.bbclass)
     ENDIANESS="${@base_conditional('SITEINFO_ENDIANESS', 'le', '--with-endianness=little', '--with-endianness=big', d)}"
     oenote Determined endianess as: $ENDIANESS
     oe_runconf $ENDIANESS
@@ -1576,7 +1576,7 @@ inherit autotools</screen></para>
           <para>The following example from net-snmp uses oenote to tell the
           user which endianess it determined was appropriate for the target
           device:<screen>do_configure() {
-    # Additional flag based on target endiness (see siteinfo.bbclass)
+    # Additional flag based on target endianess (see siteinfo.bbclass)
     ENDIANESS="${@base_conditional('SITEINFO_ENDIANESS', 'le', '--with-endianness=little', '--with-endianness=big', d)}"
     oenote Determined endianess as: $ENDIANESS
     oe_runconf $ENDIANESS
@@ -1694,7 +1694,7 @@ inherit autotools</screen></para>
           to le for little endian targets and to be for big endian
           targets:<screen>do_compile () {
     ...
-    # Additional flag based on target endiness (see siteinfo.bbclass)
+    # Additional flag based on target endianess (see siteinfo.bbclass)
     CFLAG="${CFLAG} ${@base_conditional('SITEINFO_ENDIANESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)}"
     ...</screen></para>
         </listitem>
@@ -2928,7 +2928,7 @@ fi</screen></para>
     <para>Sometimes packages require root permissions in order to perform
     some action, such as changing user or group owners or creating device
     nodes. Since OpenEmbedded will not keep the user and group information
-    it's usually preferabe to remove that from the makefiles. For device
+    it's usually preferable to remove that from the makefiles. For device
     nodes it's usually preferably to create them from the initial device node
     lists or via udev configuration.</para>
 
@@ -3268,7 +3268,7 @@ do_configure() {
           to le for little endian targets and to be for big endian
           targets:<screen>do_compile () {
     ...
-    # Additional flag based on target endiness (see siteinfo.bbclass)
+    # Additional flag based on target endianess (see siteinfo.bbclass)
     CFLAG="${CFLAG} ${@base_conditional('SITEINFO_ENDIANESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)}"
     ...</screen></para>
         </listitem>
@@ -3544,7 +3544,7 @@ which find
     all contents of the <emphasis role="bold">/var</emphasis> directory is
     lost when the device is powered off or restarted. Therefore special
     handling of <emphasis role="bold">/var</emphasis> is required in all
-    packages. Even if your distrubution does not use a tmpfs based <emphasis
+    packages. Even if your distribution does not use a tmpfs based <emphasis
     role="bold">/var</emphasis> you need to assume it does when creating
     packages to ensure the package can be used on those distributions that do
     use a tmpfs based <emphasis role="bold">/var</emphasis>. This special
index 47aa7b4..31ba613 100644 (file)
@@ -542,7 +542,7 @@ tmp/work/lzo-1.08-r14/install/lzo/usr/lib/liblzo.so.1.0.0</screen></para>
     <para>When you go about building and installing a software package there
     are a number of tasks that you generally follow with most software
     packages. You probably need to start out by downloading the source code,
-    then unpacking the source code. Maye you need to apply some patches for
+    then unpacking the source code. Maybe you need to apply some patches for
     some reason. Then you might run the configure script of the package,
     perhaps passing it some options to configure it to your liking. The you
     might run "make install" to install the software. If your actually going