qemu_cvs.bb: Fix Makefile so CFLAGS/LDFLAGS in config.mak aren't overwritten
authorDaniel Willmann <daniel@totalueberwachung.de>
Mon, 30 Jul 2007 17:12:21 +0000 (17:12 +0000)
committerDaniel Willmann <daniel@totalueberwachung.de>
Mon, 30 Jul 2007 17:12:21 +0000 (17:12 +0000)
packages/qemu/files/makefile.patch [new file with mode: 0644]
packages/qemu/qemu_cvs.bb

diff --git a/packages/qemu/files/makefile.patch b/packages/qemu/files/makefile.patch
new file mode 100644 (file)
index 0000000..75b5ac9
--- /dev/null
@@ -0,0 +1,37 @@
+Index: qemu/Makefile
+===================================================================
+--- qemu.orig/Makefile 2007-07-30 18:25:50.000000000 +0200
++++ qemu/Makefile      2007-07-30 18:26:13.000000000 +0200
+@@ -5,14 +5,14 @@
+ .PHONY: all clean distclean dvi info install install-doc tar tarbin \
+       speed test test2 html dvi info
+-CFLAGS=-Wall -O2 -g -fno-strict-aliasing -I.
++CFLAGS+=-Wall -O2 -g -fno-strict-aliasing -I.
+ ifdef CONFIG_DARWIN
+ CFLAGS+= -mdynamic-no-pic
+ endif
+ ifeq ($(ARCH),sparc)
+ CFLAGS+=-mcpu=ultrasparc
+ endif
+-LDFLAGS=-g
++LDFLAGS+=-g
+ LIBS=
+ DEFINES+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+ TOOLS=qemu-img$(EXESUF)
+Index: qemu/Makefile.target
+===================================================================
+--- qemu.orig/Makefile.target  2007-07-30 18:27:17.000000000 +0200
++++ qemu/Makefile.target       2007-07-30 18:27:23.000000000 +0200
+@@ -17,9 +17,9 @@
+ VPATH+=:$(SRC_PATH)/linux-user
+ DEFINES+=-I$(SRC_PATH)/linux-user -I$(SRC_PATH)/linux-user/$(TARGET_ARCH)
+ endif
+-CFLAGS=-Wall -O2 -g -fno-strict-aliasing
++CFLAGS+=-Wall -O2 -g -fno-strict-aliasing
+ #CFLAGS+=-Werror
+-LDFLAGS=-g
++LDFLAGS+=-g
+ LIBS=
+ HELPER_CFLAGS=$(CFLAGS)
+ DYNGEN=../dyngen$(EXESUF)
index 23589fe..8cfabb3 100644 (file)
@@ -3,10 +3,11 @@ HOMEPAGE = "http://fabrice.bellard.free.fr/qemu/"
 SECTION = "devel"
 LICENSE = "GPL"
 PV = "0.8.2+cvs${SRCDATE}"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \
            file://configure.patch;patch=1 \
+           file://makefile.patch;patch=1 \
            file://qemu-sdl-cursor.patch;patch=1 \
            file://arm_nptl.patch;patch=1 \
            file://pl110_rgb-r0.patch;patch=1 \