omap3-sgx-modules: strip unneeded stuff
[openembedded.git] / recipes / zbedic / libbedic_1.1.bb
1 DESCRIPTION = "Library to handle bedic dictionary"
2 HOMEPAGE = "http://bedic.sourceforge.net/"
3 AUTHOR = "Rafal Mantiuk <rafm@users.sourceforge.net>"
4 SECTION = "opie/libs"
5 PRIORITY = "optional"
6 LICENSE = "GPL"
7 DEPENDS = "sqlite3"
8 APPTYPE = "binary"
9 APPDESKTOP = "${WORKDIR}/zbedic/misc"
10 PR = "r3"
11
12 SRC_URI = "${SOURCEFORGE_MIRROR}/bedic/libbedic_${PV}-0.tgz"
13
14 S = "${WORKDIR}"
15
16 inherit palmtop
17 # need to override this, because bedic contains exception handling
18 # pass VERSION as a string \\"${PV}.0\\"
19 export OE_QMAKE_CXXFLAGS="-fexceptions -fno-rtti ${CXXFLAGS} -DVERSION=\\"${PV}.0\\""
20
21 do_configure() {
22         qmake -project && qmake -makefile -t lib -spec ${QMAKESPEC} CONFIG=console CONFIG+=staticlib CONFIG+=sharedlib -after \
23         TARGET=bedic \
24         SOURCES-=src/xerox.cpp OBJECTS-=xerox.o \
25         SOURCES-=src/mkbedic.cpp OBJECTS-=mkbedic.o \
26         SOURCES-=src/test_dynamic_dictionary.cpp \
27 }
28
29 do_install() {
30     install -d ${D}${includedir}
31     install -m 0644 ${S}/include/*.h ${D}${includedir}
32     install -d ${D}${libdir}
33     oe_libinstall -a libbedic ${D}${libdir}
34 }
35
36 do_stage() {
37     install -d ${STAGING_INCDIR}/libbedic/
38     install -m 0644 ${S}/include/*.h ${STAGING_INCDIR}/libbedic/
39     oe_libinstall -a libbedic ${STAGING_LIBDIR}
40 }
41
42 FILES_${PN}-dev = "${includedir} ${libdir}"