omap3-sgx-modules: strip unneeded stuff
[openembedded.git] / recipes / xorg-xserver / xserver-xorg_1.7.4.bb
1 require xorg-xserver-common.inc
2
3 DESCRIPTION = "the X.Org X server"
4 DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts"
5 PE = "2"
6 PR = "${INC_PR}.2"
7
8 SRC_URI += "file://sysroot_fix.patch;patch=1 \
9             file://dolt-fix-1.7.0.patch;patch=1 \
10             file://randr-support-1.7.0.patch;patch=1 \
11             file://hack-fbdev-ignore-return-mode.patch;patch=1 \
12            "
13
14 SRC_URI_append_angstrom = " file://hack-assume-pixman-supports-overlapped-blt.patch;patch=1"
15 SRC_URI_append_shr = " file://hack-assume-pixman-supports-overlapped-blt.patch;patch=1"
16
17 # OpenPandora HACK! - Temp! - Do NOT put into mainline.
18 SRC_URI_append_omap3-pandora = " file://evil-no-XkbSendNewKeyboardNotify.patch;patch=1 \
19                                  file://xorg-kill-ugly-pattern.patch;patch=1 \
20 "
21
22 do_install_prepend() {
23         mkdir -p ${D}/${libdir}/X11/fonts
24 }
25
26 # The NVidia driver requires Xinerama support in the X server. Ion uses it.
27 XINERAMA = "${@['--disable-xinerama','--enable-xinerama'][bb.data.getVar('MACHINE',d) in ['ion']]}"
28
29 EXTRA_OECONF += " ${CONFIG_MANAGER_OPTION} ${XINERAMA} --disable-kdrive --disable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
30 EXTRA_OECONF += " --disable-glx-tls --enable-dri2 --disable-unit-tests "
31
32 export LDFLAGS += " -ldl "