psplash: Changed to 1.72RC
[openembedded.git] / recipes / wvstreams / wvstreams_4.6.bb
1 HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
2 LICENSE = "LGPL"
3 DESCRIPTION = "WvStreams is a network programming library in C++"
4 DEPENDS = "zlib openssl (>= 0.9.8)"
5
6 SRC_URI = "http://wvstreams.googlecode.com/files/${PN}-${PV}.tar.gz \
7         "
8
9 inherit autotools pkgconfig
10
11 LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
12
13 EXTRA_OECONF = " --without-tcl --without-qt --without-pam"
14
15 PACKAGES_prepend = "libuniconf libuniconf-dbg "
16 PACKAGES_prepend = "uniconfd uniconfd-dbg "
17 PACKAGES_prepend = "libwvstreams-base libwvstreams-base-dbg "
18 PACKAGES_prepend = "libwvstreams-extras libwvstreams-extras-dbg "
19
20 FILES_libuniconf     = "${libdir}/libuniconf.so.*"
21 FILES_libuniconf-dbg = "${libdir}/.debug/libuniconf.so.*"
22
23 FILES_uniconfd     = "${sbindir}/uniconfd ${sysconfdir}/uniconf.conf ${localstatedir}/uniconf"
24 FILES_uniconfd-dbg = "${sbindir}/.debug/uniconfd"
25
26 FILES_libwvstreams-base     = "${libdir}/libwvutils.so.*"
27 FILES_libwvstreams-base-dbg = "${libdir}/.debug/libwvutils.so.*"
28
29 FILES_libwvstreams-extras     = "${libdir}/libwvbase.so.* ${libdir}/libwvstreams.so.*"
30 FILES_libwvstreams-extras-dbg = "${libdir}/.debug/libwvbase.so.* ${libdir}/.debug/libwvstreams.so.*"
31
32 PARALLEL_MAKE = ""
33
34 do_stage() {
35     autotools_stage_all
36 }
37 do_configure() {
38         autoreconf
39         oe_runconf
40 }