Merge branch 'master' of git://dev.doredevelopment.dk/oe-micro into org.openembedded.dev
[openembedded.git] / recipes / wordlist / scowl_6.bb
1 DESCRIPTION = "SCOWL (Spell Checker Oriented Word Lists) is a collection of word lists split up in various sizes, and other categories, intended to be suitable for use in spell checkers. However, I am sure it will have numerous other uses as well."
2 HOMEPAGE = "http://wordlist.sourceforge.net/"
3 LICENSE = "GPL"
4
5 SRC_URI = "${SOURCEFORGE_MIRROR}/wordlist/scowl-6.tar.gz \
6            file://rules"
7
8 S = "${WORKDIR}/${PN}-${PV}"
9
10 do_compile() {
11     cp -f ${WORKDIR}/rules ${S}
12     oe_runmake -f rules build
13 }
14 do_install() {
15     install -d ${D}/${datadir}/dict
16     install ${S}/american-english ${D}/${datadir}/dict
17     install ${S}/british-english ${D}/${datadir}/dict
18     install ${S}/canadian-english ${D}/${datadir}/dict
19 }
20
21 PACKAGE_ARCH = "all"
22 PACKAGES = "wamerican wbritish wcanadian"
23
24 FILES = "${datadir}/dict/${DICTNAME}"
25
26 pkg_postinst() {
27 #!/bin/sh
28 if [ "x$D" != "x" ]; then
29     exit 1
30 fi
31 cd ${datadir}/dict
32 ln -sf ${DICTNAME} words
33 }
34
35 DICTNAME_wamerican = "american-english"
36 DICTNAME_wbritish = "british-english"
37 DICTNAME_wcanadian = "canadian-english"