Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / t1lib / t1lib_5.0.2.bb
1 DESCRIPTION = "A Type1 Font Rastering Library"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "virtual/libx11 libxaw"
5 PR = "r5"
6 LICENSE = "LGPL GPL"
7 SRC_URI = "${DEBIAN_MIRROR}/main/t/t1lib/t1lib_${PV}.orig.tar.gz \
8            file://configure.patch;patch=1 \
9            file://install.patch;patch=1 \
10            file://libtool.patch;patch=1"
11
12 inherit autotools
13
14 EXTRA_OECONF = "--with-x --without-athena"
15 EXTRA_OEMAKE = "without_doc"
16
17 do_configure() {
18         rm -f ${S}/ac-tools/aclocal.m4
19         autotools_do_configure
20 }
21
22 do_stage() {
23         autotools_stage_all
24 }
25
26 FILES_${PN} = "${bindir}/* ${libdir}/*.so* ${datadir}/t1lib/t1lib.config"
27 FILES_${PN}-doc = "${datadir}/t1lib/doc/t1lib_doc.pdf"