sg3-utils: add newer buildable version
[openembedded.git] / recipes / syslog-ng / syslog-ng_1.6.11.bb
1 DESCRIPTION = "Alternative system logger daemon"
2 DEPENDS = "libol flex"
3 PR = "r0"
4
5 SRC_URI = "http://www.balabit.com/downloads/files/syslog-ng/sources/1.6/src/${PN}-${PV}.tar.gz \
6           file://syslog-ng.conf \
7           file://initscript"
8
9 S = "${WORKDIR}/${PN}-${PV}"
10
11 inherit autotools update-rc.d
12
13 EXTRA_OECONF = "--with-libol=${STAGING_BINDIR_CROSS}/"
14
15 do_install_append() {
16         install -d ${D}/${sysconfdir}/${PN}
17         install ${WORKDIR}/syslog-ng.conf ${D}${sysconfdir}/${PN}/syslog-ng.conf
18         install -d ${D}/${sysconfdir}/init.d
19         install -m 755 ${WORKDIR}/initscript ${D}/${sysconfdir}/init.d/syslog-ng
20 }
21
22 pkg_postinst() {
23         update-rc.d -f syslog remove
24 }
25
26 pkg_postrm() {
27         update-rc.d syslog add 5
28 }
29
30 CONFFILES_${PN} = "${sysconfdir}/${PN}/syslog-ng.conf"
31
32 INITSCRIPT_NAME = "syslog-ng"
33
34 INITSCRIPT_PARAMS = "defaults 05"