omap3-sgx-modules: strip unneeded stuff
[openembedded.git] / recipes / quake / quake3-pandora-gles_git.bb
1 DESCRIPTION = "OpenGL ES quake3 port to the omap3-pandora"
2 LICENSE = "GPL"
3
4 SRCREV = "39d08bf6e81f7cdc29380858dfe671b0722332a3"
5 PR_append = "+gitr${SRCREV}"
6 PV = "0.0"
7
8 DEPENDS = "virtual/libsdl libgles-omap3"
9
10 SRC_URI = "git://github.com/Cpasjuste/quake3_pandora_gles.git;branch=master;protocol=git \ 
11            file://quake3_makefile.patch;patch=1 \
12 "
13 S = "${WORKDIR}/git"
14
15 export PNDSDK="${STAGING_DIR}"
16
17 do_compile() {
18         cd pandora 
19         sed -i -e s:=arm-none-linux-gnueabi-:=${TARGET_PREFIX}:g Makefile
20         oe_runmake 
21 }
22
23 do_install() {
24         install -d ${D}/${bindir}
25         install -d ${D}/${libdir}/quake3/baseq3/
26
27         install -m 0755 ${S}/pandora/release${TARGET_ARCH}/baseq3/*.so ${D}/${libdir}/quake3/baseq3
28         install -m 0755 ${S}/pandora/release${TARGET_ARCH}/quake3 ${D}/${libdir}/quake3
29
30         install -m 0755 ${S}/pandora/autoexec.cfg  ${D}/${libdir}/quake3/baseq3
31         install -m 0755 ${S}/pandora/autoexec_high_detail.cfg  ${D}/${libdir}/quake3
32         install -m 0755 ${S}/pandora/autoexec_medium_detail.cfg  ${D}/${libdir}/quake3
33         install -m 0755 ${S}/pandora/autoexec_low_detail.cfg  ${D}/${libdir}/quake3
34         install -m 0755 ${S}/pandora/run.sh  ${D}/${libdir}/quake3
35 }
36
37 FILES_${PN} += "${libdir}"
38 FILES_${PN}-dbg += "${libdir}/quake3/.debug ${libdir}/quake3/baseq3/.debug"
39