omap3-sgx-modules: strip unneeded stuff
[openembedded.git] / recipes / python / python-imaging_1.1.6.bb
1 DESCRIPTION = "Python Imaging Library"
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 DEPENDS = "freetype jpeg tiff"
6 RDEPENDS_${PN} = "python-lang python-stringold"
7 SRCNAME = "Imaging"
8 PR = "ml2"
9
10 SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
11            file://path.patch"
12 S = "${WORKDIR}/${SRCNAME}-${PV}"
13
14 inherit distutils
15
16 do_compile() {
17     export STAGING_LIBDIR=${STAGING_LIBDIR}
18     export STAGING_INCDIR=${STAGING_INCDIR}
19     distutils_do_compile
20 }
21
22 do_install() {
23     export STAGING_LIBDIR=${STAGING_LIBDIR}
24     export STAGING_INCDIR=${STAGING_INCDIR}
25     distutils_do_install
26     install -d ${D}${datadir}/doc/${PN}/html/
27     install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
28     install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
29
30 }
31
32 SRC_URI[md5sum] = "3a9b5c20ca52f0a9900512d2c7347622"
33 SRC_URI[sha256sum] = "7dd7358ab519161967c838df27465282d180a3206f693ba2db64273d688b3f90"