Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / pwc / pwc_10.0.6a.bb
1 DESCRIPTION = "Philips USB Webcam driver for Linux that supports VGA resolution"
2 PRIORITY = "optional"
3 SECTION = "kernel/modules"
4 LICENSE = "GPL"
5 PR = "r1"
6
7 SRC_URI = "http://www.saillard.org/linux/pwc/files/pwc-${PV}.tar.bz2 \
8            file://endian-fix.patch;patch=1 \
9            file://Makefile"
10
11 S = "${WORKDIR}/pwc-${PV}"
12
13 inherit module
14
15 do_compile_prepend() {
16         cp -f ${WORKDIR}/Makefile ${S}/
17 }
18
19 do_compile () {
20         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
21         oe_runmake 'KDIR=${STAGING_KERNEL_DIR}' \
22                    'CC=${KERNEL_CC}' \
23                    'LD=${KERNEL_LD}'
24 }
25
26 do_install() {
27         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
28         install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
29 }
30