xfce4-battery-plugin: tune the pandora hack
[openembedded.git] / recipes / proftpd / proftpd_1.3.2e.bb
1 DESCRIPTION = "Secure ftp daemon"
2 SECTION = "console/network"
3 LICENSE = "GPL"
4 PR = "r0"
5
6 SRC_URI = "ftp://ftp.nl.uu.net/pub/unix/ftp/proftpd/ftp/distrib/source/${PN}-${PV}.tar.gz;name=src \
7         file://make.patch;patch=1 \
8         "
9 SRC_URI[src.md5sum] = "4ecb82cb1050c0e897d5343f6d2cc1ed"
10 SRC_URI[src.sha256sum] = "7c7f295944e8e7c85060829deeaed74f3f0b36c8f1d3936277d59bbea5d60093"
11
12
13
14 EXTRA_OECONF = "ac_cv_func_setpgrp_void=yes ac_cv_func_setgrent_void=yes"
15 LDFLAGS += "-Llib"
16 PARALLEL_MAKE = ""
17
18 do_configure () {
19          ./configure \
20                    --disable-auth-pam \
21                    --build=${BUILD_SYS} \
22                    --host=${HOST_SYS} \
23                    --target=${TARGET_SYS} \
24                    --prefix=/usr \
25                    --sysconfdir=/etc \
26                    --sharedstatedir=/com \
27                    --localstatedir=/var \
28                    ${EXTRA_OECONF} \
29                    $@;
30 }
31
32 do_install () {
33         oe_runmake DESTDIR=${D} install
34 }
35
36 pkg_postinst () {
37         # more chown's might be needed
38         chown root:root /usr/sbin/proftpd
39 }