e57bf08068f08610ab21376629e17b34afb0c361
[openembedded.git] / recipes / openmoko2 / neod_svn.bb
1 DESCRIPTION = "Simple Neo1973 Daemon for Button Handling and Power Management"
2 SECTION = "openmoko/daemons"
3
4 DISTRO_APM ?= "apm"
5 DEPENDS = "gtk+ pulseaudio apmd"
6 RDEPENDS = "gpe-scap xrandr alsa-utils-amixer ${DISTRO_APM} dbus"
7 PV = "0.1.0+svnr${SRCPV}"
8 PR = "r7"
9
10 inherit openmoko2 gconf
11
12 SRC_URI += "file://htc.patch;patch=1;maxrev=3348 \
13             file://ipaq.patch;patch=1;maxrev=3348"
14
15 EXTRA_OECONF_om-gta01 = "--with-platform=neo1973"
16 EXTRA_OECONF_om-gta02 = "--with-platform=neo1973"
17 EXTRA_OECONF_a780      = "--with-platform=ezx"
18 EXTRA_OECONF_a1200     = "--with-platform=ezx"
19 EXTRA_OECONF_e680      = "--with-platform=ezx"
20 EXTRA_OECONF_rokre2    = "--with-platform=ezx"
21 EXTRA_OECONF_rokre6    = "--with-platform=ezx"
22 EXTRA_OECONF_magician  = "--with-platform=htc"
23 EXTRA_OECONF_hx4700    = "--with-platform=ipaq"
24 EXTRA_OECONF_htcuniversal = "--with-platform=htc"
25
26 PACKAGE_ARCH = "${MACHINE_ARCH}"
27