strace: update to 4.10
[openembedded.git] / recipes / openmoko-projects / paroli_git.bb
1 DESCRIPTION = "Paroli"
2 SECTION = "x11"
3 LICENSE = "GPL"
4 SRCREV = "bb9fb1969acdfbaa48b55902675a6d8949014c6d"
5 PV = "0.2.1+gitr${SRCREV}"
6 PE = "1"
7 PR = "r0"
8
9 SRC_URI = "git://git.paroli-project.org/paroli.git;protocol=http;branch=shr"
10 S = "${WORKDIR}/git"
11
12 inherit distutils
13
14 PACKAGES += "${PN}-autostart ${PN}-theme ${PN}-sounds ${PN}-calculator"
15
16 RDEPENDS = "\
17   python-datetime \
18   python-subprocess \
19   python-textutils \
20   python-dbus \
21   python-pygobject \
22   python-elementary \
23   dbus-x11 \
24   task-fso-compliance \
25   elementary \
26   elementary-themes \
27   edbus-ehal \
28 "
29
30 E_CONFIG_DIR="/usr/share/enlightenment/data"
31
32 RULES_YAML = rules.yaml
33 RULES_YAML_om-gta01 = gta01_rules.yaml
34
35 do_configure_append() {
36         # fix absolute etc reference
37         sed -i "s|/etc/|../../etc/|" ${S}/setup.py
38         sed -i "s|prefix,|'../../usr/',|" ${S}/setup.py
39         sed -i "s|core/|${PYTHON_SITEPACKAGES_DIR}/|" ${S}/scripts/paroli
40         sed -i "s|services|/usr/share/paroli/services|" ${S}/scripts/paroli.fso.cfg
41         sed -i "s|applications|/usr/share/paroli/applications|" ${S}/scripts/paroli.fso.cfg
42 }
43
44 do_install_append() {
45 #       install ${D}${sysconfdir}/paroli/paroli.fso.cfg ${D}${sysconfdir}/paroli/paroli.cfg
46
47         # install paroli theme
48         install -d ${D}${E_CONFIG_DIR}/themes
49         install ${S}/data/e-config/paroli.edj ${D}${E_CONFIG_DIR}/themes/
50         install ${S}/data/e-config/serenity.edj ${D}${E_CONFIG_DIR}/themes/
51         install -d ${D}${E_CONFIG_DIR}/config/paroli
52         install ${S}/data/e-config/paroli/* ${D}${E_CONFIG_DIR}/config/paroli/
53         install -d ${D}${E_CONFIG_DIR}/config/paroli-serenity
54         install ${S}/data/e-config/paroli-serenity/* ${D}${E_CONFIG_DIR}/config/paroli-serenity/
55
56         install -d ${D}${datadir}/elementary/themes
57         install ${S}/data/paroli.edj ${D}${datadir}/elementary/themes
58
59         install -d ${D}${datadir}/icons
60         install ${S}/data/paroli.png ${D}${datadir}/icons
61
62         install -d ${D}${datadir}/applications  
63         install ${S}/data/paroli.desktop ${D}${datadir}/applications
64
65         # install autostart
66         install -d ${D}${E_CONFIG_DIR}/applications/all
67         cp ${D}/usr/share/applications/paroli.desktop ${D}${E_CONFIG_DIR}/applications/all
68         install -d ${D}${E_CONFIG_DIR}/applications/startup
69         echo "${E_CONFIG_DIR}/applications/all/paroli.desktop" >> ${D}${E_CONFIG_DIR}/applications/startup/.order
70
71 #       install -d ${D}${sysconfdir}/freesmartphone/oevents
72 #       install ${S}/data/${RULES_YAML} ${D}${sysconfdir}/freesmartphone/oevents/paroli_rules.yaml
73 #       install ${S}/data/frameworkd.conf ${D}${sysconfdir}/paroli_frameworkd.conf
74
75         install -d ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone
76         install ${S}/data/default.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml
77
78         install -d ${D}${datadir}/dbus-1/system-services/
79         install ${S}/data/dbus/org.tichy.launcher.service ${D}${datadir}/dbus-1/system-services/
80
81         install -d ${D}${datadir}/sounds
82         install ${S}/data/sounds/* ${D}${datadir}/sounds
83
84 }
85
86 pkg_postinst_${PN}-autostart() {
87 #!/bin/sh
88 # do this off or on line
89 if [ "x$D" != "x" ]; then
90         ROOTFS=${IMAGE_ROOTFS}
91 else
92         ROOTFS=""
93 fi
94
95 # post installation script
96 if [ -x $ROOTFS${sysconfdir}/X11/Xsession.d/80zhone ]; then
97    echo "*******************************************"
98    echo "Deactivating zhone autostart"
99    echo "*******************************************"
100    chmod -x $ROOTFS${sysconfdir}/X11/Xsession.d/80zhone || true
101 fi
102 exit 0
103 }
104
105 #pkg_postinst_${PN}-sounds() {
106 #!/bin/sh
107 # do this off or on line
108 #if [ "x$D" != "x" ]; then
109 #       ROOTFS=${IMAGE_ROOTFS}
110 #else
111 #       ROOTFS=""
112 #fi
113 # post installation script
114 #if [ ! -e /$ROOTFS${sysconfdir}/freesmartphone/opreferences/conf/phone/old_default.yaml ] ; then
115 #    echo "Backing up ${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml"
116 #    mv $ROOTFS${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml $ROOTFS${sysconfdir}/freesmartphone/opreferences/conf/phone/old_default.yaml
117 #fi
118 #cp $ROOTFS${sysconfdir}/freesmartphone/opreferences/conf/phone/paroli_default.yaml $ROOTFS${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml
119 #exit 0
120 #}
121
122 pkg_postinst_${PN}-theme() {
123 #!/bin/sh
124 # do this off or on line
125 if [ "x$D" != "x" ]; then
126         ROOTFS=${IMAGE_ROOTFS}
127 else
128         ROOTFS=""
129 fi
130 # post installation script
131 echo 'E_PROFILE="-profile paroli"' > $ROOTFS${sysconfdir}/enlightenment/default_profile
132 exit 0
133 }
134
135 FILES_${PN} = " \
136         ${sysconfdir}/dbus-1 \
137         ${sysconfdir}/paroli \
138         ${sysconfdir}/freesmartphone/oevents \
139         ${prefix}/lib \
140         ${prefix}/bin \
141         ${datadir}/paroli/applications/common-for-edje \
142         ${datadir}/paroli/applications/inout \
143         ${datadir}/paroli/applications/telephony \
144         ${datadir}/paroli/applications/messages \
145         ${datadir}/paroli/applications/launcher \
146         ${datadir}/paroli/applications/people \
147         ${datadir}/paroli/applications/settings \
148         ${datadir}/applications \
149         ${datadir}/elementary \
150         ${datadir}/paroli/services \
151         ${datadir}/paroli/data \
152         ${datadir}/pixmaps \
153         ${datadir}/icons \
154         ${datadir}/dbus-1/system-services/ \
155         "
156
157 FILES_${PN}-theme = " \
158         ${E_CONFIG_DIR}/themes \
159         ${E_CONFIG_DIR}/config \
160         "
161
162 FILES_${PN}-autostart = "${E_CONFIG_DIR}/applications"
163
164 FILES_${PN}-sounds = " \
165         ${datadir}/sounds/ \
166         ${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml \
167         "
168
169 FILES_${PN}-calculator = " \
170         ${datadir}/paroli/applications/calculator \
171         "
172
173 CONFFILES_${PN} += " \
174         ${sysconfdir}/paroli/paroli.fallback.cfg \
175         ${sysconfdir}/paroli/paroli.pyneo.cfg \
176         ${sysconfdir}/paroli/paroli.fso.cfg \
177         "
178 CONFFILES_${PN}-sounds += " \
179         ${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml \
180         "