xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / recipes / openjade / openjade_1.3.2.bb
1 SECTION = "unknown"
2 DEPENDS = "opensp"
3 RDEPENDS = "sgml-common"
4 DESCRIPTION = "OpenJade is a suite of tools for validating, \
5 processing, and applying DSSSL (Document Style Semantics and \
6 Specification Language) stylesheets to SGML and XML documents."
7 LICENSE = "BSD"
8 SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
9            file://configure.patch;patch=1"
10
11 inherit autotools
12
13 EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
14                 --enable-splibdir=${STAGING_LIBDIR}"
15
16 acpaths = "-I ${S}/config"
17
18 # Trailing whitespace is important. Otherwise compiler arguments will be messed
19 # up, resulting in a fail in do_configure.
20 CFLAGS_prepend = "-I${S}/include "
21
22 do_configure_prepend () {
23         mv config/configure.in .
24 }
25
26 do_stage () {
27         oe_libinstall -a -so -C style libostyle ${STAGING_LIBDIR}
28         oe_libinstall -a -so -C spgrove libospgrove ${STAGING_LIBDIR}
29         oe_libinstall -a -so -C grove libogrove ${STAGING_LIBDIR}
30 }