xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / recipes / net-snmp / net-snmp_5.4.2.1.bb
1 require net-snmp.inc
2 PR = "${INC_PR}.1"
3
4 SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.tar.gz \
5         file://configure-tail.patch;patch=1 \
6         file://CVE-2008-6123.patch;patch=1 \
7         file://init \
8         file://snmpd.conf \
9         file://snmptrapd.conf"
10
11 EXTRA_OECONF = "--enable-shared --disable-manuals --with-defaults \
12                 --disable-embedded-perl --with-perl-modules=no"
13 EXTRA_OEMAKE = "INSTALL_PREFIX=${D}"
14
15 do_configure_prepend() {
16         gnu-configize -f
17         # We better change sources and re-autoconf here, but
18         # required autoconf is too new for us.
19         sed -e '/echo.*\".*\\\\.*\"/s/echo/echo -e/g' \
20             -e 's/tail -1/tail -n 1/g'                \
21             -i configure
22
23         #The tarball for v5.4.2.1 is missing config.sub
24         cp ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
25 }
26
27 PARALLEL_MAKE = ""
28 CCACHE = ""